1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Sputtering On Acceleration

Posted by sexycholo, Apr 8, 2005

Please Support Rix Racing
Please Support ExtremePSI
  1. sexycholo

    sexycholo Proven Member

    8
    0
    Joined Jan 22, 2005
    Manassas, Virginia
    my 96 gst sputters when it hits 12lbs. it used to go to 16lbs. but now it dosent. when any of my gears hit 12lbs it sputters and feels like fuel cut. It back fires constantly like sh**, once it hits 12lbs. i went to many shops they dont know sh**. timing,compression, is perfect. All clamps are tight and vacums are all in place. everything is tight. does the same thing. IM STUCK< DONT KNOW WHAT TO DO.
    I have:
    255 walbro
    greddy 3" turbo back
    upper intercooler p/p
    greddy blowoff valve
    greddy fmic
    8.5 mag spark wires
    new plugs
     
  2. blackGSX2g

    blackGSX2g DSM Wiseman

    2,931
    81
    Joined Apr 30, 2004
    Kalamazoo, Michigan
    I'd do a boost leak test. Visual boost leak tests do not count, hook an air compressor up to it and see what it looks/sounds like at 15-20 psi. You'd be suprised at all the holes and slits that can show up when you feed it some boost.

    If that all checks out fine, it could be your 255 is over-running your fuel pressure regulator (assuming you don't have an aftermarket one). Either get a new FPR, or take the pump out and swap it for either your stock one or a 190 till you get a regulator.

    just my .02
     

    1K  0

    1995 Eagle Talon TSi AWD
    11.866 @ 120.750 · 2G DSM
    Loading...
  3. HSK

    HSK Proven Member

    170
    0
    Joined Nov 21, 2003
    Orange County, California
    change or check the spark plugs and wires.
     
  4. Mack

    Mack Proven Member

    169
    1
    Joined May 7, 2003
    Cleveland, Ohio
    Has the fuel filter ever been changed? That covers poor performance. As for the boost, I too would check for leaks. With that much boost, what plugs are you currently running and gapped at?
     
  5. Dual-Tipped

    Dual-Tipped Proven Member

    49
    0
    Joined Feb 5, 2004
    Saskatoon,
    leak in your boost controller
     
  6. sexycholo

    sexycholo Proven Member

    8
    0
    Joined Jan 22, 2005
    Manassas, Virginia
    ok i put the stock fuel pump. it felt a little better. but it still does the same thing at 12 psi. by the way i raced a prelude 2000 yesterday and i was sputtering and crap. and i could only press 3/4 of the acclerator so wouldnt sputter and wouldnt shoot up to 12 psi. i smoked his ass on 2 gear and left him in 3rd. i won 100 dollars. > im getting frustrated.
     
  7. sexycholo

    sexycholo Proven Member

    8
    0
    Joined Jan 22, 2005
    Manassas, Virginia
    i have no boost controller on. b/c it would be worse if i did. boost is stock
     
  8. GILZTSIAWD

    GILZTSIAWD Proven Member

    563
    10
    Joined Feb 4, 2004
    petal, Mississippi
    did you check plugs, wires, and the fuel filter as stated above? it sounds like you are either starving it of fuel, feeding it too much fuel, or not getting spark, which definitely points to those things. just give the whole thing a good tune-up and see if that helps you out, alot of times you can see a huge difference from a tune-up. good luck
     
  9. canucatchdis

    canucatchdis Proven Member

    151
    0
    Joined Jan 2, 2003
    Moline, Illinois
    I agree with HSK. Try changing the spark plug wires. I know my car will feel like it wants to fall on its face if the wires are bad. And its unbelieveable how drastically the car will change in a few days time. One day it will fine and then drastically worse as the days go on.
     
  10. sexycholo

    sexycholo Proven Member

    8
    0
    Joined Jan 22, 2005
    Manassas, Virginia
    Thanks Guys. It Was The Spark Plugs. The Shop Put The Wrong Ones. Dum Bastards. Lol. Yep Its Fixed Now Running Strong . Thanks
     

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com