The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Rix Racing
Please Support ExtremePSI

Latest activityPostingsVehiclesAbout

    • 97gsxmod reacted to Crazyjoker77's post in the thread 2G Resistor Pack with Like Like.
      okay folks spent the last hour looking through 20 pages without any help i REALLY need to know the location of the resistor pack on 2g turbo models i looked through http://members.shaw.ca/dsm.1000q/Engineprimer/2G/index.htm and it only shows the...
    • 97gsxmod replied to the thread Rain short?.
      Thanks. Installing a new negative cable and ground cause mine looks like shit. I’ll check the draw when I get everything hooked back up
    • 97gsxmod reacted to CKOPOCT's post in the thread Rain short? with Like Like.
      A parasitic draw will draw the battery down to 0 given enough time. Depends on how long the car is sitting. Charge the battery up and then clamp the + cable to the battery. Next, put a test light between the neg post and the neg post clamp. If...
    • My battery keeps draining to all the way down to 1-2 volts. This is the second battery I’ve ruined like this. I’ve never seen the battery at say 10,9,8 volts , just 11-12 or 1-2… does this sound like a short? Doesn’t happen all the time so I’m...
    • 97gsxmod replied to the thread 2G Engine issues?.
      Ok thought I tried this before but I guess the ecu wasn’t on auto save. Raised target idle to 1100 rpm and she started and held idol just fine! But I also installed the wideband that’s in between my front and rear o2 sensor but it’s not giving me...
    • 97gsxmod reacted to Justin DuBois's post in the thread 2G Engine issues? with Like Like.
      10 min and some cash for the beers at a local muffler shop, and it would be good.
    • 97gsxmod replied to the thread 2G Engine issues?.
      That’s exactly what I need!
    • 97gsxmod reacted to RamenPride's post in the thread 2G Engine issues? with Like Like.
      JB weld is going to burn off (even if it claims to be heat resistant to 1000 degrees). If you can't weld the bung, you can get one that clamps on.
    • 97gsxmod replied to the thread 2G Engine issues?.
      Yea I’ll probably have to buy a welder but went the cheap and lazy route. I’ll keep an eye on it and most likely at least put some spot welds on it soon
    • 97gsxmod reacted to steve's post in the thread 2G Engine issues? with Like Like.
      Depending on where you are putting the bung it's not likely to last. In the exhaust manifold the temps can normally exceed 1200F. It's gets cooler the farther you get from there but it still plenty hot when it reaches the Cat.
    • 97gsxmod replied to the thread 2G Engine issues?.
      thanks! i think thats most likely the culprit. i probably just noticed this issue less because it was warmer out.been waiting for the rain to stop to jb weld in this wideband bung that i just drilled a whole for. its 1000 degree heat resistant...
    • 97gsxmod reacted to chrisman287's post in the thread 2G Engine issues? with Like Like.
      My front O2 doesn’t work and my car still idles… I don’t think that’s your issue
    • 97gsxmod reacted to Justin DuBois's post in the thread 2G Engine issues? with Like Like.
      Adjusting the TPS won’t increase the air needed to hold idle when cold, so scratch that.You could try opening the BISS to let more air in, similar to cracking the throttle plate by hand, but when things get to operating temps, the idle will be...
    • 97gsxmod replied to the thread 2G Engine issues?.
      Going to look into the throttle body being blocked off. Would this cause the car to not idol? It’s just confusing me because the only thing that’s really changed besides the built turbo is the fact that on of the o2 sensors in the front was...
    • 97gsxmod reacted to Justin DuBois's post in the thread 2G Engine issues? with Like Like.
      It is easier to adjust the global dead time with a working front o2 sensor, but if that is not working, you can still try altering the global dead time and see how the idle is affected. Try getting it running, and then slowly increase or...
    • 97gsxmod replied to the thread 2G Engine issues?.
      And my car actually currently has two dangling un Installed but plugged in 02 sensors . One hanging in the rear, one hanging in the front, and then the one that’s actually installed in the front , so just wanted to clarify the dangling o2 censor...
    • 97gsxmod replied to the thread 2G Engine issues?.
      My latest theory is that the car previously had some mechanical or ecu issue that won’t allow it to idle in open loop. This would explain why previously I needed to rev the car for about 5ish seconds before it would hold idol. When I put an...
    • 97gsxmod replied to the thread 2G Engine issues?.
      and this one i set some more tables and settings to stock. didnt seem to hurt or help much by the sound of things, but again im not able to deduce from the log if they helped or hurt?
    • 97gsxmod replied to the thread 2G Engine issues?.
      i started this one without clicking the non 95-96 style cam angle sensor setting, then engaged the non 95-96 style cam angle sensor , then disengaged the setting, but i couldnt tell a difference from the feel of the car and wasnt able to deduce...
    • 97gsxmod replied to the thread 2G Engine issues?.
      set injectors to 1200cc. seemed to end the black smoke and misfiring problems, must have been causing it to run rich. but it still wont hold idle?
  • Loading…
  • Loading…
  • Loading…
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned
Back
Top