The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support JNZ Tuning
Please Support Fuel Injector Clinic
Ki263737
Reaction score
1

Latest activityPostingsAbout

    • Ki263737
      Could my ECU coolant temp sensor be the issue? At operating temp its down some ohmsI used my friends laser as reference his was at .24 and mine was between .19-.20 ohms
    • Ki263737
      Anybody know what these 4 wires are there is a r/g, b/y, w/b, b/r i don't know what they are for but wanna make sure they are not important wires came from they radio harness or around that areaalso checked timing and the CAS and they are fine
      • 20240608_173658.jpg
      • 20240608_173602.jpg
    • Ki263737
      fair point I don't have a timing light so rn so i can check the CAS tomorrow but that bring me to my next question how can i tell if it is on 180 degrees off?still gonna take the dash out fix the wire for the pin and replace my heater core at...
    • Ki263737
      I'm not spending money on parts between me and my buddy we have 6-7 1g dsm's now that most my parts have been fromI don't think it's timing due to the fact the car has done nothing but sit since the last ECU died or the last issue could just...
    • Ki263737
      Did some wire testing and got 12volt on the room Fuse but not to my ECU on pin 103.
    • Ki263737
      Started just checking all the boost pipes and such and this line popped out without any resistance could this be an issue
      • 20240601_151310.jpg
    • Ki263737
      So I have sourced the ECU off eBay and confirmed the ECU numbers matched the ones on my old ECU. After I got the new ECU I opened the case and inspected the ECU. The ECU looked fine and was a non EPROM ECU and used it (put the only photo I had of...
      • image_2024-05-30_164339251.png
    • Ki263737
      The last ECU failed and wouldn't trigger the MPI relay to send spark but with a new one it now has yellow looking spark could that also be an possible issueAnd just realized i haven't said it is vary much over fuelling (black smoke from exhaust)
    • Ki263737
      No aftermarket boost gauge and CEL comes on for 5 secs then stays off I also know for a fact its not the ECU since all the parts I have replaced have been from a previously running car (until I pulled them) including the ECU.
    • Ki263737
      Ok was curious as I've head that it could cause some issues just didn't knownif it could cause mine other things I have don't to the car is plugs, plug wires, coil pack, power transiter, fuel rail, fuel regulator, injectors, and am going to...
    • Ki263737
      Took awhile but started working on the car again and noticed that my dome lights don't work anymore. Could that mean that I'm not getting backup power to my ECU through pin 103?
  • Loading…
  • Loading…
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned
Back
Top