Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource on the web



















Login



Go Back   DSMtuners > DSM Forums > 420A DSM Tech > 420A Engine Management
Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource
You are browsing the site as a GUEST. Please login (or register) and gain the ability to post on our site and interact with other DSMers. You also get to browse the site with fewer advertisements. It is FREE to join!

420A Engine Management: EPROMS, ECU, MAF, knock, EGT, wideband, datalogging, etc - specific to 2G N/T DSMs.

Reply  
 
LinkBack   Thread Tools
Old 05-05-2007, 07:50 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #1 (permalink)
Proven Member
 

lilbayz311's Avatar
Registered: Feb 2005
Tech Posts: 101
Photos: 4
Classifieds Rating: 0
Reputation: lilbayz311 is more helpful than not

bad ecu symptoms? or asd relay?


my car has died multiple times out of nowhere with no noticable cause. most of the time it only happens when it gets hot. but after it had time to cool off it would usually just fire right up. the most recent time i pulled the head to replace a low compression piston, when it was all ready to start for the frst time we cranked it and no start. we looked into it and discovered that the coilpack gets 12 volts only right after the key is turned to the "on" position for about 2 seconds and then goes back to 0 no matter if we are cranking or what. we have found that the injectors are not getting their power either. we looked into the asd relay and when we grounded the proper wire manually the asd relay clicks and the ignition has a consistant 12 volts. but still no start. why does the coil only get its power for about 2 seconds right after the key is turned to on, then drop right back to 0 again? we didnt touch any wiring during this last rebuild besides to unplug them. we checked and double checked all of our wiring. do you think i need a new ecu or asd relay? thats just the jist of it let me know if you need more specifics and ill let you know. i cant think of any other cause to this strange prolonging problem than something to do with the ecu. please let me know what you think asap with strong support; i dont want to have to buy a new ecu if i dont have to.

View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 06-21-2007, 09:19 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #2 (permalink)
Proven Member
 

poonman's Avatar
Registered: May 2006
Tech Posts: 498
Photos: 5
Classifieds Rating: 0
Reputation: poonman is more helpful than not
Send a message via MSN to poonman Send a message via Yahoo to poonman
do you have and cel's
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 06-21-2007, 11:35 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #3 (permalink)
Proven Member
 

BigRand's Avatar
Timeslip: 14.337 @ 98.390
Registered: Nov 2004
Tech Posts: 1,818
Photos: 17
Classifieds Rating: 4
Reputation: BigRand is extremely helpful and trustworthyBigRand is extremely helpful and trustworthyBigRand is extremely helpful and trustworthy
Send a message via Skype™ to BigRand
Check your EGR pipe, and make sure it hasn't burn't any wires up...this will kill the connection to different important things that keep your car running....mine shut down on the freeway for no reason at all...then it would start up when it cooled down,but would die again shortly after.

If you do a seach about this you can find more detailed stories of it happening to other people and see if it resembles what is going on with you.


____________________________
-Randy: Boosted since 05/05
Visit BigRand's homepage!  View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Reply

Bookmarks

Thread Tools

 

» Recent DSM Photo
» Current Poll
How many times have you been to the Shootout?
1 - 39.86%
167 Votes
2-5 - 41.77%
175 Votes
6-10 - 10.50%
44 Votes
11-15 - 3.10%
13 Votes
16-20 - 4.77%
20 Votes
Total Votes: 419
You may not vote on this poll.
» Online Users: 449
109 members and 340 guests
Most users ever online was 1,704, 03-17-2008 at 09:11 PM.
DSMtuners Main Sections
DSM Forums
DSM Regional Forums
DSM Builds/Journals
DSM Articles
DSM Tech Guides
DSM Upgrade Paths
DSM Parts Reviews
DSM Vendor Reviews

DSM Classifieds
DSM Parts Guides
DSM Photos
DSM Videos
DSM Timeslips
DSM Dyno Sheets
Shirts & Apparel
DSMtuners Decals

Advertising Info
Our Sponsors
Site Rules
Terms of Service
Privacy Policy
Site FAQ
About Us
Contact Us

© 2014 DSMtuners.com - All Rights Reserved

DSMtuners is not affiliated with Diamond Star Motors. The Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, Mitsubishi Galant VR-4, and associated logos are trademarks of Diamond Star Motors, Mitsubishi Motors, and Chrysler Corporation. No, we do not hand out car sponsorships.

All times are GMT -7. The time now is 01:07 AM.


Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0