The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Morrison Fabrications
Please Support STM Tuned

2G Won't stay running!

DSMgirl15

Probationary Member
10
0
Mar 11, 2018
Saluda, Virginia
My car starts up but won't stay running, it will idle for a few seconds and then cut off. I'm not sure what it could be any suggestions?
 

ChessmoDSM

Proven Member
468
200
Apr 22, 2017
Burlington, Vermont
We need way more information to start troubleshooting, can you fill out a profile with current mods, and a background on the issue(when did it start happening, have you done anything to troubleshoot? eg replacing parts ect)..
 

DSMgirl15

Probationary Member
10
0
Mar 11, 2018
Saluda, Virginia
Just did an engine swap on my 97 eclipse hat with an 95/96 engine. Did all the proper adjustments to make the conversion work. The car started multiple time and stayed running. Went to go start it again the next day now it starts but only idles for a few seconds and then cuts back off.
 

ChessmoDSM

Proven Member
468
200
Apr 22, 2017
Burlington, Vermont
Again, there are a plethora of variables to consider for this issue, your best bet is to create a profile with all of this information(How about the swap, is this a 4G63T or a 420a?) Did you replace all timing components, do you have DSMlink if its a 4G63T? A profile will be the quickest way to get help now and moving forward.

Right now your guess is as good as ours.. :aha:
 

boost97gst

Proven Member
3,033
133
Apr 2, 2012
st jacob, Illinois
You have DSMLink? Since it ran WITH the engine swap, i am assuming you accounted for the different cam sensor(i'm rusty, forgive me). I would go with the standard troubleshooting method on a IC engine: Fuel, Spark, Compression. You sound like you have a fuel delivery issue. That is a wild ass guess with zero info though
 

1990TSIAWDTALON

Moderator
9,283
5,079
Nov 14, 2013
Independence, Kansas
Is it out of gas?
Fuel pump come on?
Fuel pressure to the rail?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top