1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

ECMlink wide band and tuning idle help

Posted by byAzon, Apr 5, 2020

Please Support Fuel Injector Clinic
Please Support STM Tuned
  1. byAzon

    byAzon Proven Member

    45
    2
    Joined Jul 27, 2019
    Cheyenne, Wyoming
    hi guy i finally got my car running and idling with no surging and no cel. today i boost leak tested and smoke tested to 15 psi my waste gate is only 12 and that's what i plan on running for now so i can drive my car and enjoy since i haven't gotten to drive it since i got it which was a year and half ago. mods are: walbro 450, 1250 fic , hy35 with a morrison fab o2 downpipe, speed density mistu style, ecmlink, arp studs, oem composite head gasket, all new gaskets after,arlet adjustable fuel pressure at 42psi , aem eugo wideband . im not really looking to turn it up but just to be able to cruise it around. also i recently clean my o2 sensor and did a free air calibration test cause i may have forgot wont lie but ant ways at idle my gauge is reading around 11.2-12.1 but mostly in the 11 afrs. but on ecm link its logging at 14.1-14.8 so i don't know which one to believe really. also any advice really helps first car i belt so im still learning as i go so thanks in advance for the help!
     

    Attached Files:

  2. ThunderChild

    ThunderChild Supporting VIP

    2,861
    950
    Joined Jan 5, 2012
    Rathdrum, Idaho
    Sounds like you need to input the correct injector deadtime values, have you already done that? If you have, then you may need to adjust at global fuel to compensate.
    Is your car a 2g? I assume so since your fuel pressure is set as high as it is. 1g- 38psi and 2g- 43.5psi IIRC.
     

    Street Build 593  3

    1990 Plymouth Laser N/T
    fwd · manual · 1G DSM

    620  8

    1987 Toyota Pickup/Hilux
    awd · manual · Misc Vehicles

    Street Build 1K  7

    1997 Mitsubishi Eclipse Spyder GST
    fwd · manual · 2G DSM

    2K  0

    1992 Eagle Talon TSi AWD
    manual · 1G DSM

    Street Build 3K  10

    1992 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    byAzon likes this.
  3. Vegas smith

    Vegas smith Proven Member

    3,058
    1,605
    Joined Dec 2, 2002
    Houston, Texas
    Your map sensor doesn't appear to be working coorectly. It's reading a constant number. Your narrowband o2 isn't cycling either. It might be stuck in open loop.
     

    Street Build 4K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    byAzon likes this.
  4. byAzon

    byAzon Proven Member

    45
    2
    Joined Jul 27, 2019
    Cheyenne, Wyoming
    i did put the global and dead times that the injectors came in and it was idling around 10-11 so i lowered global dead times and got it to 12.5 afrs and yes sirits a 2g gsx
     
  5. byAzon

    byAzon Proven Member

    45
    2
    Joined Jul 27, 2019
    Cheyenne, Wyoming
    how would i get my map sesnor to read properly since i went the mistu style. and how would i get my narrow band to starter cycling sorry if these are like newbie questions i never played but really wanna learn with ecmlink or any tuning soft ware thanks for the replys
     
  6. Vegas smith

    Vegas smith Proven Member

    3,058
    1,605
    Joined Dec 2, 2002
    Houston, Texas
    Under the ecu inputs tab, you checked the lock MDP. Perhaps that's the issue? I've never tuned a 2g so maybe not. Uncheck that and see what happens.
     

    Street Build 4K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    byAzon likes this.
  7. byAzon

    byAzon Proven Member

    45
    2
    Joined Jul 27, 2019
    Cheyenne, Wyoming
    so i did unlock the mpd and it didnt really make a diffrence and i let it get to temp and it didnt really change anything.
     
  8. EVLGSX

    EVLGSX Proven Member

    510
    217
    Joined Dec 7, 2017
    Wallingford, Connecticut
    To answer your original question-
    If this is an older AEM Wideband, you need to set it up as Linear and manually enter the proper voltage values to get Link to match up with what the face of the gauge reads.
    Gofer made a great video showing how to do this. Can be found on youtube.

    Also leave MDP locked if you are not using the stock MDP sensor anymore. ( sounds like you replaced the MDP sensor located on top of the plenum with a MAP sensor correct?)

    I would
    -use Baro channel for the MAP sensor

    -Hook your wideband up to the rear o2 input

    -Re install the the factory narrowband (front o2)

    -And then you will have the MDP channel open to log something useful someday when you get there

    -If nothing else, assuming the injector data is correct, focus on learning how to use WB factor to dial in your SD table ( once you get it logging accurately)
     
    Last edited: Apr 6, 2020

    Street Build 2K  15

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
    byAzon and 1990TSIAWDTALON like this.
  9. byAzon

    byAzon Proven Member

    45
    2
    Joined Jul 27, 2019
    Cheyenne, Wyoming
    So I do have a rear o2 in as well but I did notice yesterday someone before me was playing around with the wiring so I wonder if that’s why it won’t cycle to the rear. And just a question that I’m generally curious what would switching around my o2 sensors do? I’ll definitely watch that video about adjusting my wide band so it reads the same thank you for answering that question! And when ur talking about the baro channel your talking about switching it so it shows my map sensor instead of baro? Cause I have my onmi 4 bar being displayed which yes it’s on top on the manifold.
     
  10. 1990TSIAWDTALON

    1990TSIAWDTALON Moderator

    5,222
    2,542
    Joined Nov 14, 2013
    Independence, Kansas
    Short term and Long term fuel trims are high. I like to adjust the global (use the FIC injector settings that were with the 1250's) to get the STFT's within +-5%. Your ECU is having to add fuel so adjust the global to a little bit less negative number and try to bring the STFT's down to as close to zero as you can get.
    Just trying to help out as it is what I would do.
    Marty
     

    Street Build 4K  29

    1992 Eagle Talon TSi AWD
    14.74 @ 117.04 · 1G DSM

    1K  14

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    703  18

    1967 Chevrolet Camaro RS
    rwd · automatic · Misc Vehicles

    Street Build 970  7

    1998 Eagle Talon TSi
    fwd · manual · 2G DSM

    Street Build 6K  13  25

    1990 Eagle Talon TSi AWD
    13.620 @ 108.460 · 1G DSM
    Loading...
  11. EVLGSX

    EVLGSX Proven Member

    510
    217
    Joined Dec 7, 2017
    Wallingford, Connecticut
    Honestly, before you go much further with this, you need to spend hours, reading, taking notes, and learning more about what your trying to do. We can help you once your in the ballpark, but you are so far out right now, its inefficient for us to explain every little thing.......

    Go to the EMClink forums and read. Its going to take some doing. You gotta want it. But its worth it.

    If you are serious and you want to do this, you will be back in no time asking questions that make sense.

    You will get better help when it is clear that you have put in some effort as well.
     

    Street Build 2K  15

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
    byAzon and ThunderChild like this.
  12. jed344

    jed344 Supporting VIP

    666
    70
    Joined Jan 10, 2008
    Waterville, Iowa
    Taking a quick peak at the log I see a lot wrong honestly. ISC position is at 8, should be around 30. Fuel trims are threw the roof meaning car is thinking its lean so adding a ton of fuel. That's why your wideband is showing rich because ecu is adding max fuel it can. TPS is off should be .63v at idle and 5v at wot.
    Your map sensor appears to be locked in vacuum at -20.3in. At idle ignore the wideband and even cruse turning honestly. Tune off the fuel trims you want them within 5% of zero. This is the confusing part. Your wideband says its rich so you will think I need to pull fuel. That is wrong the fuel trims say its lean. The car actually needs more fuel at idle. What fuel is the car on? I see you have simulate wideband turned on but it is not simulating. Im going to guess your front O2 pegged at .20V is a big part of the problem to start with. For some reason I cannot see closed loop operation. Is it going into closed loop? sorry for long post just a lot I see off.
     

    1K  26

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory