The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support RTM Racing
Please Support ExtremePSI

What did you do to your DSM today?

Gwaihir

Proven Member
62
9
Jun 18, 2018
CHELMSFORD, Massachusetts
It was a busy couple of days.

Pulled the original 20 year old factor starter out of my 98 Talon TSI AWD and installed a Bosch starter.

Replaced the positive battery terminal connector with a “beefier” new connector.

Traced a boost leak to my type rs bov. The bov outlet connecting into my MAF housing had wiggled loose a bit. Tightened that up.

Cleaned my SMIC a bit with a dry brush, will hit it with some cleaner later. Was dirtier than I thought.

Took out the stock air box and installed a K&N FIPK.
 

97 eclenger

Proven Member
460
42
Jan 22, 2014
Durham, North_Carolina
I pulled the whole interior including carper out of my 92 laser rs. So far a total of 4 rat nests have been found.
 

FirstTimeDSM

Probationary Member
21
0
Aug 18, 2018
Missoula, Montana
Not entirely sure to be honest. Went from first and shifted to second at like, 5,500 or maybe 6k. Shifted into second and at around 3,500 in second, heard a loud POP. Not SUPER loud but noticeable. Drove about 1/8th of a mile back to work(Delivery driver) which was weird because immediately after the popping sound, i was locked out of my gears, couldn't shift to them if i tried, then after wiggling it in neutral a few times and going back to second everything was fine. anyways, got back to work and a 3x3 puddle of tranny fluid came out when i parked in the parking lot, lots of chattering as i towed it home in neutral. so i jacked it up and got under there and this is what i seen.
You must be logged in to view this image or video.

You must be logged in to view this image or video.


First gear was kicked back out at me prior to this happening if i wasn't at high rpms/holding it up into first. Then it started doing a fairly loud ticking noise ONLY in first. Assumed it was a synchro or a 1-2 fork bent, was gonna drop it that night and take a look, then literally 15 minutes before my shift ended. This. So. Yeah, Guess they weren't kidding when they say you'll always be working on your dsm LOL
 

RipperXX

Proven Member
5,793
163
Feb 23, 2003
Royston, Georgia
Not entirely sure to be honest. Went from first and shifted to second at like, 5,500 or maybe 6k. Shifted into second and at around 3,500 in second, heard a loud POP. Not SUPER loud but noticeable. Drove about 1/8th of a mile back to work(Delivery driver) which was weird because immediately after the popping sound, i was locked out of my gears, couldn't shift to them if i tried, then after wiggling it in neutral a few times and going back to second everything was fine. anyways, got back to work and a 3x3 puddle of tranny fluid came out when i parked in the parking lot, lots of chattering as i towed it home in neutral. so i jacked it up and got under there and this is what i seen.
You must be logged in to view this image or video.

You must be logged in to view this image or video.


First gear was kicked back out at me prior to this happening if i wasn't at high rpms/holding it up into first. Then it started doing a fairly loud ticking noise ONLY in first. Assumed it was a synchro or a 1-2 fork bent, was gonna drop it that night and take a look, then literally 15 minutes before my shift ended. This. So. Yeah, Guess they weren't kidding when they say you'll always be working on your dsm LOL

That's only true if you keep trying to go faster and drive it hard as crap for the way it's built. I'm content with a high 12 sec 4cyl that corners VERY hard and gets 30mpg on the highway and doesn't ever seem to need much more than an oil change and gasoline. Has had one or two electrical problems this year, but what do you expect form a nearly 30yr old wiring harness...

Speak of which, does anyone have a source for the ECU temp sensor pigtail for a 90? Mines pretty much toast, every now and then it shorts and the ECU thinks the cars coolant temp is either 300*F or -60*F but it works 99.5% of the time so I have been ignoring it.
 

Dsm panda

Proven Member
234
57
Dec 8, 2017
Franklin, Wisconsin
Changed every bushing in my talons shifter changed the oil and trans fluid. Got new injector seals in, they where leaking bad. Wired up my wideband into ecmlink which was also installed recently. Going to start it let it idle and then I need to pull the turbo and send out for a rebuild in the next few weeks here. Going to drain the oil again and put some better oil in then she just needs some tires and should be ready to be driven again.
 

Gwaihir

Proven Member
62
9
Jun 18, 2018
CHELMSFORD, Massachusetts
Gave my Talon a fresh look. Headlight and corner light swap. Still trying to decide how I want to wire my halos. Thinking I’ll tap the corner lights. I already have the headlights as DRL with the proper setup due to this being a Canadian build.

Getting a timing belt and water pump replacement this week. Have NGK coils, plugs, and wires on the way along with a walbro l190.

She’s running good right now. Should be like brand new soon :)
 

Attachments

  • F27EA61E-3850-4C10-B6C4-942E33F44D3D.jpeg
    F27EA61E-3850-4C10-B6C4-942E33F44D3D.jpeg
    680.8 KB · Views: 104
  • 0C0C5AAC-B399-4C11-93D7-7129A819A91C.jpeg
    0C0C5AAC-B399-4C11-93D7-7129A819A91C.jpeg
    522.7 KB · Views: 143

b00zt3d spyd3r

Proven Member
275
26
Feb 25, 2016
Lawton, Oklahoma
Stopped a power steering leak from when I replaced the rack and couldn't get hose on all the way. It also had one of those bs squeeze hose clamps so I reached my arm in the smallest of space to put a real hose clamp on and get hose all the way on. It was a bi***. Also fixed a couple boost leaks
 

DogWhistle

Supporting VIP
842
365
Sep 13, 2012
St. Paul, Minnesota

007jimmy

Proven Member
1,617
191
Feb 27, 2012
Levittown, Pennsylvania
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
Continuing my black interior swap. Keeping the dash and console gray for the mean time. Not to mention the plastic black handles that housed the switches were trashed. Cleaned and scrubbed the black leather seats and swapped out the better foam cushions. Doors will be scrubbed next. The magic eraser worked wonderfully for the seats!!
 

ThunderChild

Supporting VIP
3,758
1,125
Jan 5, 2012
Rathdrum, Idaho
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.


Finally got time to try v2 of my w2a intercooler reservoir. Got much better welds this time, also used .190" 5052 instead of the 3/32" 5052 I was using. Also changed over to .030" wire after I ran out of .035" and it seemed to work alot better.

Here's v1... I bailed after seeing the debacle unfolding and ruining a couple of my -16an weld on fittings. Mind you, v1 was the second time I used the spool gun, v2 is the 3.5th time (I practiced kn a scrap of the new material right before diving in haha)

You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.


Still alot to improve on and learn, but I'm happy with v2. Biggest thing was prep, planning and sticking with the steps, like don't put the AN bungs on before doing the rest of the welding... :ohdamn:
 

99-420a

Probationary Member
25
3
Jun 30, 2018
Newark, Ohio
Reinstalled my engine and solved a couple little bugs I was having with it.
No leaks or knocks started first try.
Will be going turbo soon. Got to buy a manifold and waste gate and intercooler core. Would have had it already but had to buy injectors for my Infiniti.
 

Attachments

  • 20180903_124715_Film3.jpg
    20180903_124715_Film3.jpg
    394.9 KB · Views: 90

1990TSIAWDTALON

Moderator
9,466
5,299
Nov 14, 2013
Independence, Kansas
Cut the rear brake lines out of my 92 Talon. All rusted and blew a hole in one, so new tubes are going in this weekend.
 

Kryndon

Proven Member
860
509
Jan 10, 2014
Bulgaria, Europe
Connected a light switch for the glove box (why was it ever disconnected??) and cleaned the interior. Hey, it's still something!
 

fredom dsm

Proven Member
324
44
Jan 31, 2006
Denton, Texas
Built a bracket for my catch can and another one for my Map sensor( I know its not map but cant remember the name)
 

Attachments

  • C82D8C6B-5663-4470-8D91-83A77BD0F7E2.jpeg
    C82D8C6B-5663-4470-8D91-83A77BD0F7E2.jpeg
    357.8 KB · Views: 85
  • 5A61CF9D-332D-40DB-9947-14B9410B8820.jpeg
    5A61CF9D-332D-40DB-9947-14B9410B8820.jpeg
    394.1 KB · Views: 74
  • 68BEE11D-57A9-49A4-AC97-1BB9325BA6F7.jpeg
    68BEE11D-57A9-49A4-AC97-1BB9325BA6F7.jpeg
    258.9 KB · Views: 107
  • 4ACE2686-A85B-47A8-9AF8-EDE961662CA0.jpeg
    4ACE2686-A85B-47A8-9AF8-EDE961662CA0.jpeg
    440.5 KB · Views: 83
  • 1DEA802D-E524-42FF-88AE-30638AA6BB06.jpeg
    1DEA802D-E524-42FF-88AE-30638AA6BB06.jpeg
    356.7 KB · Views: 90
  • 1F185BB1-10A0-4EA3-ACAF-BCDA8E8EBAF0.jpeg
    1F185BB1-10A0-4EA3-ACAF-BCDA8E8EBAF0.jpeg
    469.1 KB · Views: 83
  • F7C28F3F-F072-4C39-B56F-82AF0E883379.jpeg
    F7C28F3F-F072-4C39-B56F-82AF0E883379.jpeg
    427 KB · Views: 99
  • 2FE29FBA-122D-4F42-BD25-AED75EAA72F4.jpeg
    2FE29FBA-122D-4F42-BD25-AED75EAA72F4.jpeg
    425.1 KB · Views: 71

Kenny07

Proven Member
132
29
Jan 15, 2014
clovis, New_Mexico
Tore apart the interior, ran the OHM racing Fuse box and engine harness, deleted heater core. Pressure washed the engine bay to get ready for a fresh coat of paint.
 

Attachments

  • 57CF2F1E-5EBB-4130-B184-76207F60A864.jpeg
    57CF2F1E-5EBB-4130-B184-76207F60A864.jpeg
    465.8 KB · Views: 110
  • 70AF0306-F6F8-4069-8DEA-554A199BC527.jpeg
    70AF0306-F6F8-4069-8DEA-554A199BC527.jpeg
    547.4 KB · Views: 96
  • F24FBBB1-037F-4ACC-82E8-5C12971EE5B1.jpeg
    F24FBBB1-037F-4ACC-82E8-5C12971EE5B1.jpeg
    646.7 KB · Views: 104
  • 2A83B045-05AA-479E-A07F-0312EBB9DDC7.jpeg
    2A83B045-05AA-479E-A07F-0312EBB9DDC7.jpeg
    498.2 KB · Views: 77

1990TSIAWDTALON

Moderator
9,466
5,299
Nov 14, 2013
Independence, Kansas
Started the car after a lot of small upgrades. Didn't run long but was happy it started. More work tonite!
Got the Volk Tube Front end on also!! :thumb:
Thanks @99gst_racer !!!
You must be logged in to view this image or video.
You must be logged in to view this image or video.


Out with the old!!!!
You must be logged in to view this image or video.
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top