The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support STM Tuned
Please Support ExtremePSI

Together, but alternator problem?

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

MrPikolo

20+ Year Contributor
1,345
0
Aug 9, 2002
Winterport, Maine
Alrighty, my car is complety together from the auto-manual swap. Everything seems to run fine, exepct for one thing. When I rev the engine to about 4,000 rpm, the lights flicker. As they get brighter, not dimmer. Anyone have any ideas?

Also, what would make your blinker blink really quickly? My hazards go fine, but my blinkers blink like crazy. Any help would be greatful. Thanks.

~John
 
Get a voltmeter and check how much power your battery is getting when idling. You shoudl see at leist 12.8 volts. If not then your alt may be taking a doodle on you. Check belt tension, fuses and make sure the little knob on the cluster is actually turned all the way bright:D

As for the lights that an open circuit. Could be grounding somewhere or you could just be missing a bulb somewhere also... voltmeter should hlep in diagnosing this as well.
 
Heh, yeah I belive there are 2 missing lights up front. And it could be the battery, cause the batter light is also on, but its very dim.

The coolent light is also on, but its very dim and flickers slightly. There is enough coolent in the car I belive. Any suggestions about that?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top