The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support STM Tuned
Please Support ExtremePSI

1G Something wrong with car during boost. Please help!!!

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

100shotofNOS

20+ Year Contributor
32
0
Jun 10, 2002
Alabama
I read in another forum that this happened to someone else's car but I cant find it now.

Half way through my boost the car jumps or bucks. I was running 14-15psi. I checked all the hoses & wires, spark plugs but everything looks ok. My check engine light comes on too.
 
Originally posted by 100shotofNOS
I read in another forum that this happened to someone else's car but I cant find it now.

Half way through my boost the car jumps or bucks. I was running 14-15psi. I checked all the hoses & wires, spark plugs but everything looks ok. My check engine light comes on too.

How do you know it's not the plugs/wires, did you swap them out? Visual inspection of these things often shows very little. I would swap in a known good set from another car to verify.
 
Originally posted by 100shotofNOS
I just bought and put in a new set of plugs and wires. How would I check the coil & transistor

There's a procedure in the FM for checking them both out.
 
If the engine light comes on then the car is triggering a CEL. Find out which one and work from there.
 
I have the same problem I think. My car feels like its hesitating like the clutch is slipping. I just put a new clutch and flywheel in a couple hundred miles ago. Do you guys think I should do the same?
 
Did you mess up you're oil seal when you installed the clutch?





Originally posted by Libila
I have the same problem I think. My car feels like its hesitating like the clutch is slipping. I just put a new clutch and flywheel in a couple hundred miles ago. Do you guys think I should do the same?
 
Originally posted by Libila
I have the same problem I think. My car feels like its hesitating like the clutch is slipping. I just put a new clutch and flywheel in a couple hundred miles ago. Do you guys think I should do the same?

Does the RPM of the car increase while speed remains the same? If so then your clutch is slipping in gear. Did you have the flywheel cut and resurfaced properly?
 
I know this cant be my problem. It makes no sense but I left the cover off that goes over the spark plugs and it runs fine, I put it back on and the problem comes back, so I've been driving it without the cover for two days and everything is working again. Is it safe to drive without the cover?
 
Damn Jim^^^^^ J/K....... 100SHOT, I am no wiseman but I have had mine off for a while and as far as I know it has done no wrong for me. :)
 
Had the exact same problem a few months ago, my car would run fine up to about 3-5 PSI of boost but if I went past those numbers it would buckle, hesitate as if it was running on 2 cylinders. The CE light would turn on too. The CE light code was for a faulty coil pack or power transistor. It ended up being neither, as we figured out that when the CE light turned on and the car buckled, 2 fuel injectors had stopped receiving a signal from the ECU....source for the buckling and hesitation plus the CE light.
That's right the ECU was FAULTY!!!.......had it repaired and haven't had a problem since then.
Just my 2cents.
 
Get an ohm meter and probe the connectors on your old ones and get the factory specs i.e-All Data, Chiltons ect.







Originally posted by 100shotofNOS
I just bought and put in a new set of plugs and wires. How would I check the coil & transistor
 
Im still confused with my car. It boosts fine but its not smooth when I get past 3k rpm. No CEL or anything, suggestions?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Latest Classifieds

Back
Top