The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support JNZ Tuning
Please Support Rix Racing

Running to Lean

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

littlenug98

Probationary Member
4
0
Oct 10, 2002
Greenbrook.NJ
Hello,

My car has been running to lean ever since I change my Bov to a new one.
I recently had a first gen bov and I decide to change it to a greddy type s bov. then suddenly my car isn't running the same.

my friend recommend me to change both my o2 sensor.. which i did.. but it still the same result..

everything time i gun my car.. it suddenly run fine, but it get a big push of extra power.. i check my air/fuel ratio.. it lean all the time when i do it.. if i press on the gas lightly it rich.. i dont know why it doing it...

HELP< HELP
 
How do you know you're running lean; what's telling you this? blinky air/fuel gauge, egt gauge, pocketlogger, timing gettin pulled?
 
air/fuel ratio

plus when i got my car dyno about 3 week
the mechanice told me your car is running lean which isnt good for the car..
he ask me if i replace my o2 sensor for my car.. which i told him no..
i order and replace both my o2 sensor last week
and the car still running lean!!
 
is it any less lean now that you replaced the sensors? Just wondering if it made any deference...


All i know to say other wise is check for leaks infront of the turbo.. I doubt that is the problem... but you never know.. also if it's realy a problem and theres nothing wrong with the other 1G BOV just switch back...???
 
Did you stick with the stock BOV? If not, maybe check to see if there is a problem there. Obviously you are losing air somewhere between your MAF and your intake mani, and since you just changed your BOV, I think that might have something to do with the problem. Maybe make sure no intercooler pipes got loosened when the install took place. (If its an adjustable BOV, try to tighten it down a bit)

Good luck man!

Brian
 
How lean are we talking here? What O2 or a/f are you seeing under WOT? What are you EGT's after a 3rd gear pull?

It could be a clogged fuel filter, dying pump, or something else. What are you using to tune?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top