The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support JNZ Tuning
Please Support ExtremePSI

Spyder Questions and suggestions please.

tonydl

Probationary Member
11
0
May 3, 2021
Prineville, Oregon
So i have a 97 eclipse spyder gst and lately have had over heating issues,i had to replace my radiator,i did my timing and water pump also,i bled the system the best you can,my guage reads correctly but ill climb pretty fast if i dont have my heater on,im not sure what it is exactly but the radiator is made for the 2.0 turbo dohc,ive done my thermostat too and still cant seem to keep it cool any suggestions?also was curious im running the stock toyo intercooler could i maybe need a new one?the only upgrades would be my camshafts and lifters,but allot of newer parts on the car already.soooo just needing some input on some things and maybe just ideas of what i could do or should do?
 

NOSLO2PT0

Proven Member
2,688
241
Aug 31, 2002
Joliet, Illinois
Sounds like you got air trapped in the system still. Gotta burp it. Keep squeezing the lower radiator hose with the cap off until u don’t see any more air bubbles coming out
 

tonydl

Probationary Member
11
0
May 3, 2021
Prineville, Oregon
Sounds like you got air trapped in the system still. Gotta burp it. Keep squeezing the lower radiator hose with the cap off until u don’t see any more air bubbles coming out
Ok ill try that again for sure
 

SixBolt_16G

Proven Member
102
9
Nov 7, 2005
Chicago, Illinois
Several things...

Air trapped in system.
Defective thermostat/water pump even tho they are new
Missing heat shields
Fans not functioning properly
You wouldve seen it working on the radiator but has intense heat warped/disfigured your fans reducing the flow?
Front mount IC blocking the flow to the radiator?

or perhaps several of these issues all contributing to the overall issue?

Just for more information, do you notice it climbing just by idling? Does the temp start to drop if you start driving?
 
Last edited:

tonydl

Probationary Member
11
0
May 3, 2021
Prineville, Oregon
So im pretty sure it was air in the system i ended up just drowning it with water while squeezing the bottom hose repeatedly and its not over heating now,funny thing is now im having an issue with my vac,i droped 5 pounds in vac randomly and im taking out plugs and checking wires as we speak,also clutch is soft after changing fluids,i did 2 ways,first push clutch down have someone hold twist screw then close screw pull peddle up,the other way i did it is similar but at the end i left the pedal down and manual pushed the slave rod towards the slave held it in place and put the bleed screw back in im not sure if im just doing it wrong or what but todays been the day for f*** ups LOL.
 

luv2rallye

DSM Wiseman
8,220
1,048
Jun 7, 2003
Minneapolis, Minnesota
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top