The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Kiggly Racing
Please Support ExtremePSI

Oil pressure light

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Todd95TSi

20+ Year Contributor
223
0
Dec 28, 2002
Indiana, Pennsylvania
I just did an oil change with Valvoline synthetic blend and a PureOne filter. I initially put 4.5qts. in and the oil pressure light would flash and come on at idle, so I poured the other half quart in. The oil pressure light is still coming on at idle. Whats going on?
 
You've overfilled your crankcase for starters, drain it back to the Full mark.
Then replace your light sender, it's too worn out to function properly. Back of the block.
 
Originally posted by gixrman
Mine just came on today. The stock gauge reads about half and the dipstick is at the full level. I use Mobil 1 never had this before, only does it at idle. I hope its the pressure sender and not something else.
It is. If you ever hear a hydraulic-lifter motor lose oil pressure, it's a sound you'll never forget. Kinda like mom using the Singer to sew up a suit of armor made out of aluminum cans.
If you go a grade higher in viscosity, they'll probably never make a sound.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top