The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support ExtremePSI
Please Support VR-Speed Factory

Need help w/1990 eagle talon Tsi - Fault codes

Soggy Wonka

Probationary Member
17
5
Jun 5, 2021
Le Sueur, Minnesota
Would the boost valve solenoid if faulty make any issues or if vacuum lines backwards?. Only reason I say this is because he had the head decked and then back together. Missed a connection? He drove it for a bit then broke down. So it sat since 2018 in a garage
 

pauleyman

DSM Wiseman
6,553
1,728
Nov 19, 2011
oklahoma city, Oklahoma
Would the boost valve solenoid if faulty make any issues or if vacuum lines backwards?. Only reason I say this is because he had the head decked and then back together. Missed a connection? He drove it for a bit then broke down. So it sat since 2018 in a garage
No
 

Soggy Wonka

Probationary Member
17
5
Jun 5, 2021
Le Sueur, Minnesota
That's a good point but thats an awfully stock looking engine bay.

Op is this car modded?

Code 31??? Or 13? When a car flags 12, 13 and 25 that's a common sequence when somebody ran the car without the maf plugged in. Im Betting your maf wasn't bad. You should check the codes again.
If the boost gauge hasn't been reassigned you need to look closer at all the piping. Possible tear in an intercooler hose, hole in intercooler etc.
That's a good point but thats an awfully stock looking engine bay.

Op is this car modded?

Code 31??? Or 13? When a car flags 12, 13 and 25 that's a common sequence when somebody ran the car without the maf plugged in. Im Betting your maf wasn't bad. You should check the codes again.
If the boost gauge hasn't been reassigned you need to look closer at all the piping. Possible tear in an intercooler hose, hole in intercooler etc.
I did connect the old MAF and it pulled the same codes 12,25,31.. installed new one and now only have 31
 

Soggy Wonka

Probationary Member
17
5
Jun 5, 2021
Le Sueur, Minnesota
Here are the 4 lines under the intake manifold I was talking about. Where do they go? Plus put a new knock sensor. Same issue. Next is a boost leak treat and then to fuel. Also found a #3 wire was cracked. Even thou new

You must be logged in to view this image or video.
 

Soggy Wonka

Probationary Member
17
5
Jun 5, 2021
Le Sueur, Minnesota
Thanks so much. I have already eliminated 2 of the 3 codes..(2 of the codes were for the MAF) which I was hoping was the problem.. I guess not.. ordered a knock sensor so when that gets here I will replace that. In the mean time I will go another boost leak test tomorrow. Plus I found 4 vacuum connections under the intake manifold next to motor. Maybe a issue.. I'll take a pic of them tomorrow and post
No more CEL light thou. That's a plus... Lol
 

NOSLO2PT0

Proven Member
2,305
48
Aug 31, 2002
Joliet, Illinois
Here are the 4 lines under the intake manifold I was talking about. Where do they go? Plus put a new knock sensor. Same issue. Next is a boost leak treat and then to fuel. Also found a #3 wire was cracked. Even thou new

You must be logged in to view this image or video.
Those are all emissions related. Get rid of them
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top