The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support STM Tuned
Please Support STM Tuned

2G Misfire when warm at low RPM - stock, no CEL

ErikTande

Supporting Member
1,470
502
Dec 17, 2012
Centennial, Colorado
Got a 1997 Talon TSi I'm having a misfire / stumble / miss problem with. It's fine when it's cold, but when it's warm it starts to misfire at low RPM and at idle. Higher RPMS seem ok. Car is bone stock.

Plugs and wires have been changed, and I assumed it was the ICM so I swapped that out. No change. It was a junkyard part ICM though so it's possible they were both bad...

No history on the car, I just got it.

What do I check next? Thanks!
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top