The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support STM Tuned
Please Support STM Tuned

1G Misfire, Popping noise

AllenTallen

Proven Member
39
22
Oct 3, 2020
Houston, Texas
Hey guys hope all is well. Just got the car running back up after a year. I’ve change a good amount since the last start up but here is a small list of the main things:

Walbro 450 (rewired)
2150cc injectors
AFPR
E-85
Speed density
FP-green turbo
EGR delete
FMIC

I’m having a misfire on idle. Around 2,000RPM and up it doesn’t break up or anything and runs pretty strong through the RPM. I’ve hit it a good 3 times to 5,500RPM to get a good log on ECMlink so I can tune the car properly.

When I first got the car last year I hit the two-step and fouled the plugs. So I change the plugs and wires to (NGK BPR6ES .28)(NGK 9634) and since then I’ve drove the car maybe 50 miles. They don’t visually look bad.

I changed the coil pack today & checked motor grounds. I did confirm spark on 1234 as well. Thanks everyone for the help. Much appreciated. I dropped a video below the exhaust is dumped below the motor.

You must be logged in to view this image or video.
 

jpmxrider489

Supporting VIP
2,347
104
Apr 4, 2010
pittsburgh, Pennsylvania
You should be running ngk br7es or br8es if you run higher boost. Mainly for e85. This is what Kevin (my tuner) recommended to me.

The video does sound like metal. Check the exhaust and heat shields. Shouldn't be that hard. If it's a misfire, post a log. The rpm will be wavy (not smooth) with a misfire.
 

Sirius1995

Proven Member
79
12
Jun 15, 2021
Hattiesburg, Mississippi
does it only does that when engine is warm or when engine is cold as well?
 

AllenTallen

Proven Member
39
22
Oct 3, 2020
Houston, Texas
You should be running ngk br7es or br8es if you run higher boost. Mainly for e85. This is what Kevin (my tuner) recommended to me.

The video does sound like metal. Check the exhaust and heat shields. Shouldn't be that hard. If it's a misfire, post a log. The rpm will be wavy (not smooth) with a misfire.
Thank you! Just changed to 7es and car does feel smoother but doesn’t get rid of the sound at all. The sound of more of a popping out of the Dow pipe. If you put your hand under the Down pipe you can feel the vibration from the noise it’s making. If that make sense?
 

AllenTallen

Proven Member
39
22
Oct 3, 2020
Houston, Texas
You should be running ngk br7es or br8es if you run higher boost. Mainly for e85. This is what Kevin (my tuner) recommended to me.

The video does sound like metal. Check the exhaust and heat shields. Shouldn't be that hard. If it's a misfire, post a log. The rpm will be wavy (not smooth) with a misfire.
I have pictures of idle
You must be logged in to view this image or video.
 

DSMPT

DSM Wiseman
1,634
1,176
Jun 12, 2014
Japan / Mexico, Arizona
Maybe it's only to me but it sounds like exhaust leak. I would check all exhaust parts connections and make sure no gasket is blown and no bolt/nut is loose. Especially O2 housing gasket, downpipe gasket, wastegate fire ring, wastegate dump pipe and all bolts/nuts/clumps. Of course also exhaust manifold gasket, turbine housing to manifold gasket.
 

Sirius1995

Proven Member
79
12
Jun 15, 2021
Hattiesburg, Mississippi
Do you have adjustable cam gears? Maybe timing is slightly off, mine was Poppin and banging when revving 5000rpm, it was slightly off and exhaust side was slightly open when ignition cycle was going on, when head has been done to your car last time? Maybe it needs to be tapped?
 

AllenTallen

Proven Member
39
22
Oct 3, 2020
Houston, Texas
Maybe it's only to me but it sounds like exhaust leak. I would check all exhaust parts connections and make sure no gasket is blown and no bolt/nut is loose. Especially O2 housing gasket, downpipe gasket, wastegate fire ring, wastegate dump pipe and all bolts/nuts/clumps. Of course also exhaust manifold gasket, turbine housing to manifold gasket.
Ok I will definitely double check! All gaskets are new but definitely need to varify again. Thank you. I nice 1990 you have there :cool:
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com Raven Fabrication RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top