The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Morrison Fabrications
Please Support ExtremePSI

2G Low power at low rpm

Noahrieke

Proven Member
67
6
Mar 17, 2020
Billings, Montana
I recently replace my front main seal and obviously had to take the timing belt off and all that good stuff but when I put it all back together the car seemed off at complete stop the car would idle up to 1300 and then shoot down to 800 and then back to what I have it set has which is 1100. And In first from a complete stop as I’m letting the clutch out at about 2500rpm it would just shoot down to 900 and start bogging the car till the rpm got back up. Did I not time it correctly or something? Thanks for any responses- Noah Rieke
 

pauleyman

DSM Wiseman
8,298
2,843
Nov 19, 2011
oklahoma city, Oklahoma
So would being like one tooth off do this?
Yes. Car does not run right with teeth off. Check the marks. At the very very least get number 1 to tdc with a screwdriver and check cam timing. Not as good as using the crank mark but you should be able to tell
 
Last edited:

Noahrieke

Proven Member
67
6
Mar 17, 2020
Billings, Montana
Yes. Car does not run right with teeth off. Check the marks. At the very very least get number 1 to tdc with a screwdriver and check cam timing. Not as good as using the crank mark but you should bable e to tell
Alright I’ll try do that once all this damn snow melts Montana life for you. Thanks for your help!
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top