The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support VR Speed Factory
Please Support Southbay Fuel Injectors

2G Hesitating to accelerate beyond 3T rpm in between shifts

wildbull mazula

Probationary Member
8
0
May 10, 2016
Dubai, Asia
Hi guys,
A newbie here, I just had my 95 DSM 4G63T rebuilt the second time around due to crankwalk all necessary replacement have been done and still now holding back when I shift specially on the 1st and 2nd gear, it is also felt on the higher gears when I go beyond 4T. For a brief history of what's been done or replaced-My engine is kept stock, except for Quaife LSD, Walbro 400LPH, FP exhaust manifold, Apexi downpipe, ARP bolts, Cometic Stainless gaskets, Teflon Gasket for Intake manifold, Kings Tri-Metal crankshaft bearings, Gates Timing Belts, Nology Hot wires on NGK BPR7ES, Fidanza Flywheel, ACT clutch, AEM WideBand Eugo, Glowshift Oil Temperature Gauge, Manual Boost controller and Glowshift Boost Gauge, Aluminum radiator and silicone hoses, heads are ported and polished, tranny have been overhauled too. I run on 95 octane super, all sensor are replaced OEM brand new-CAS, CPS, water pump and oil pump OEM bnew, valve seals, piston rings, vacuum hoses replaced, my ECU now is EPROM, ECM-Link on stand by for tuning after 1T kms break in. (I still have a non EPROM ECU I removed for isolation of problem) Still on MAF, stock BOV (HKS BOV SQ IV removed for isolation of problem) and turbo kept stock still in great shape and spool. I haven't finished break in yet and it is already showing problems like this.
 
Last edited:

chrysler kid

Proven Member
2,306
407
Dec 20, 2002
Mckinney, Texas
Hi guys,
A newbie here, I just had my 95 DSM 4G63T rebuilt the second time around due to crankwalk all necessary replacement have been done and still now holding back when I shift specially on the 1st and 2nd gear, it is also felt on the higher gears when I go beyond 4T. For a brief history of what's been done or replaced-My engine is kept stock, except for Quaife LSD, Walbro 400LPH, FP exhaust manifold, Apexi downpipe, ARP bolts, Cometic Stainless gaskets, Teflon Gasket for Intake manifold, Kings Tri-Metal crankshaft bearings, Gates Timing Belts, Nology Hot wires on NGK BPR7ES, Fidanza Flywheel, ACT clutch, AEM WideBand Eugo, Glowshift Oil Temperature Gauge, Manual Boost controller and Glowshift Boost Gauge, Aluminum radiator and silicone hoses, heads are ported and polished, tranny have been overhauled too. I run on 95 octane super, all sensor are replaced OEM brand new-CAS, CPS, water pump and oil pump OEM bnew, valve seals, piston rings, vacuum hoses replaced, my ECU now is EPROM, ECM-Link on stand by for tuning after 1T kms break in. (I still have a non EPROM ECU I removed for isolation of problem) Still on MAF, stock BOV (HKS BOV SQ IV removed for isolation of problem) and turbo kept stock still in great shape and spool. I haven't finished break in yet and it is already showing problems like this.

Well, what blow off valve are you running
 

pauleyman

DSM Wiseman
6,462
1,675
Nov 19, 2011
oklahoma city, Oklahoma
So wha have you checked? You have link. Log it and post it. Did you check fuel? Mechanical timing? Vacuum? What have you checked?
 

wildbull mazula

Probationary Member
8
0
May 10, 2016
Dubai, Asia
Well, what blow off valve are you running
Previuously, it was fitted with HKS SSQV4 then I read somewhere that while on MAF air must be recirculated back otherwise it will cause problems so it is now back to its stock for the meantime until I change to a GM MAP and SD kit
 

wildbull mazula

Probationary Member
8
0
May 10, 2016
Dubai, Asia
What injectors are you running?
What ECU are you driving on?
What fuel Pressure is your AFPR set to?

What injectors are you running?
What ECU are you driving on?
What fuel Pressure is your AFPR set to?
Injectors are stock
ECU is EPROM type I haven't installed yet my ECM Link when the car is done 1T kms break in we will install and tune accordingly.
AFPR is set at 45
 

wildbull mazula

Probationary Member
8
0
May 10, 2016
Dubai, Asia
So wha have you checked? You have link. Log it and post it. Did you check fuel? Mechanical timing? Vacuum? What have you checked?
We done rebuild of the engine, after all the checks we zeroed on the loose wirings on the MAF connector and rectified and fixed all the loose and frayed wirings and it did it some good on the performance of the car.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top