The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support JNZ Tuning
Please Support Fuel Injector Clinic

2G fuel leaking from left cylinder

import47

Probationary Member
26
2
Oct 6, 2020
San Antonio, Texas
95 gst stock with 255 fuel pump and I'm leaking fuel from the left cylinder no fuses blown

It is fuel and not oil

You must be logged in to view this image or video.
 

import47

Probationary Member
26
2
Oct 6, 2020
San Antonio, Texas
Mpi relay can I use a 3000or mighty Max mpi as a replacement or does it have to be the one for eclipse

Just want to know before I sit in the same spot or have to get a stm block and hack at wires
 

miguelmcv

Supporting Member
2,720
249
May 3, 2009
Fresno, California
I don’t know about the Mighty Max MPI, but what makes you think is bad?, is the clicking noise coming out of the Mpi relay?
Do you have run an overall test to see what is getting or what not, like fuel or spark, I know it was running before but things can happen while working on it.
Does the fuel pump turns on right after turning the switch to the on position.

Let us know what makes you think the sensor is no good.
 

import47

Probationary Member
26
2
Oct 6, 2020
San Antonio, Texas
I have new ptu sparkplugs wire coils new battery rebuilt ecu from ecm new rc engineering injector's 440cc new fuel pump and filter new pressure regulator and the only the left would be the mpi
It started and died but then just cranks

Plus the mighty Max did have a 4g63 and 3000 variant had one also but I also saw the mpis for them and appear to be the same externally but interanl different or not but would mitsu make one type and run with it
 

miguelmcv

Supporting Member
2,720
249
May 3, 2009
Fresno, California
Ok you have all new but is all working?,

Ok this is how things gets easier to find.
Check to see if you have fuel, you can hear the fuel pump kicking in when you turn the key to the on position (no cranking) it will turn on for 3,5 seconds, then it will turn off, if you don’t here this noise, then Something is wrong with the fuel system, even if it was working correctly before.

Maybe you have done this before, but because you have a new problem, you have to start all over again.

There is frustration to start all over again , I know, believe me I being there many times, and the only easier thing to find the problem is go through all over again.

Check for fuel,
Check for spark,
There is more to check but that’s one of the things that can cause your problem.
I always have carburetor cleaner, that’s very handy to check for fuel, I just spray a bit in the intake and rank it, if it starts, I know for sure is fuel related.

Let us know
 

import47

Probationary Member
26
2
Oct 6, 2020
San Antonio, Texas
So the mpi is same as 3000 Galant and mighty Max
But I have yet to get it till Tuesday
So I decided to toss back the sacricial 255 walbro pump back on and it started right up no delay and was running fine
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top