The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support RTM Racing
Please Support ExtremePSI

FIRST DSM STREET BUILD!!!

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

i used to have 3 pages of things i wanted to do to this thing to make it perfect. i can count on both hands how many things i have left. its honestly sad i have nothing to work on til i get my trans back.
i dont have the energy to wet sand and buff this thing again, so ill pay someone once its running and driving.
i have acouple carbon pieces i still want to get.
soon soon soon man soo soon 🙏🏼

View attachment 713307

View attachment 713308
That DSM placard is sick! Haha, love it.

Dude, 8hundo ain't bad!

Boosted pulls, coming soon!
 
That DSM placard is sick! Haha, love it.

Dude, 8hundo ain't bad!

Boosted pulls, coming soon!
thanks man it should touch up the engine bay very nicely!
yeah $800 wasnt to bad that was him cutting me a deal to, least i know it wasnt the clutches i upgraded he said all that was fine 🤟🏼
and yes sir some nasty boosted pulls coming soon, im only an hour and half away from boosted performance too, so i got to save up a chunk of money and i want them to professionally tune it. hopefully its a nasty unit
 
thanks man it should touch up the engine bay very nicely!
yeah $800 wasnt to bad that was him cutting me a deal to, least i know it wasnt the clutches i upgraded he said all that was fine 🤟🏼
and yes sir some nasty boosted pulls coming soon, im only an hour and half away from boosted performance too, so i got to save up a chunk of money and i want them to professionally tune it. hopefully its a nasty unit
For sure.
Yeah, that's awesome he hooked you up.
Oh, shit, hell yeah, got to if you're that close. Gonna be a fun ripper, no doubt.
 
its go time bitches 🤟🏼 hopefully i can get it installed tonight

IMG_2112.jpeg
 
everything is going well besides this and boost leaks my bov is f***ed, besides that, the first picture is when i took the trans out for the very
first time, no issues with anything then.
second picture everythings put back the same way but the flexplate to torque converter bolts are
hitting the left lower plate in the last photo

IMG_2139.png


IMG_2140.png


IMG_2141.png
 
If you skimmed the head of the bolt with a grinder would it be enough? Or are we talking more than a 1/16"?
 
update: I NEEDED A SPACER FOR THE 6 bolt swap
i searched high and low ever since i got this car to figure out every damn part i needed, and everything went very well intel we tried to pair the motor to the trans, yes there was a oem spacer but mixed answers on forums were saying it wasnt needed it was needed so i learned the hard way that the SPACER IS NEEDED, when we got it and finished putting it back together and firing it up from the previous owner the first time i actually got it to move it snapped the flex plate. now i know why. because there was no spacer. spacer fit perfectly everything lined up everything went back together perfectly 🤟🏼 so now to piece it back together here and figure out if this baby will fire. i need a new blow off valve mines leaking from the inside of it when i was running a boost leak test. this is the desired dsm life right? 😂😂💀
 

Attachments

  • IMG_2212.jpeg
    IMG_2212.jpeg
    548.6 KB · Views: 18
  • IMG_2211.jpeg
    IMG_2211.jpeg
    534.1 KB · Views: 19
  • IMG_2210.jpeg
    IMG_2210.jpeg
    571.7 KB · Views: 21
  • IMG_2209.jpeg
    IMG_2209.jpeg
    643.1 KB · Views: 19
  • IMG_2208.jpeg
    IMG_2208.jpeg
    362.7 KB · Views: 19


this is video when we broke the flexplate 2 years ago when we first got it to run from the previous owner. im 100% positive it broke because of no spacer
 
old bov (the greddy) was leaking so i changed it back to the turbo xs one that came with the car. is it to close to the throttle body the way i have it? should i spin it around? after getting this hooked up i went thru a series of boost leak tests and was pretty pleased. 5 pounds couple leaks here and there, getting up to 9 pounds couple more leaks here and there, 14 pounds im getting this absolute awful scream coming from one of the clamps on the bottom intercooler pipe. so i will need to upgrade from the janky ole hose clamps. but it does hold around 14 pounds now pretty sweet 🤟🏼
after we were done with that we went on to start testing for spark and trying to figure out how to set up fuel pressure, unfortunately after acouple turn overs the starter had died. so off to warranty and hopefully i can get this mf started shitt

IMG_2345.jpeg


IMG_2347.jpeg


IMG_2349.jpeg


IMG_2346.jpeg


IMG_2350.jpeg


IMG_2348.jpeg


IMG_2351.jpeg


IMG_2352.jpeg


IMG_2353.jpeg
 
BIG THINGS HAPPENING!!!
so got the starter changed out that was easy all good now turns over like a dream, so then came the fun part checking for spark. we popped plug out set it on the valve cover nothing shoot! we also tried connecting to ecmlink but got hit with “no response received” so on come all the thoughts of it could literally be anything. so grabbed a multi meter and went to work, power at coil was good, spark plug wires were swapped out, new plug, power at ignition, verified 1g cas was wired correctly, thought i tested the right mpi relay, so then i noticed the check engine light wasn’t coming on when i turn it to acc, swapped the bulb out just un cause, then came the forums they said you should have 12volts at pin 12 and 25, and i was not. spent a bunch of time checking everything had to call it a night. now i went back on the forums and was looking thru pictures of the mpi relay and had a small thought that wasnt looking the same as what i tested yesterday, so i get to the shop and i go searching for my relays and nothing but two empty plugs just sitting there. wow. off to the parts store got a relay! great now to plug it in and see what happens! check engine light comes on and we can connect to ecmlink🤝🏼 we also got spark now. time for fuel pressure 🤝🏼

IMG_2436.jpeg
 
BIG THINGS HAPPENING!!!
so got the starter changed out that was easy all good now turns over like a dream, so then came the fun part checking for spark. we popped plug out set it on the valve cover nothing shoot! we also tried connecting to ecmlink but got hit with “no response received” so on come all the thoughts of it could literally be anything. so grabbed a multi meter and went to work, power at coil was good, spark plug wires were swapped out, new plug, power at ignition, verified 1g cas was wired correctly, thought i tested the right mpi relay, so then i noticed the check engine light wasn’t coming on when i turn it to acc, swapped the bulb out just un cause, then came the forums they said you should have 12volts at pin 12 and 25, and i was not. spent a bunch of time checking everything had to call it a night. now i went back on the forums and was looking thru pictures of the mpi relay and had a small thought that wasnt looking the same as what i tested yesterday, so i get to the shop and i go searching for my relays and nothing but two empty plugs just sitting there. wow. off to the parts store got a relay! great now to plug it in and see what happens! check engine light comes on and we can connect to ecmlink🤝🏼 we also got spark now. time for fuel pressure 🤝🏼

View attachment 718082
Love those moments - nice breakthrough.
 
update: I NEEDED A SPACER FOR THE 6 bolt swap
i searched high and low ever since i got this car to figure out every damn part i needed, and everything went very well intel we tried to pair the motor to the trans, yes there was a oem spacer but mixed answers on forums were saying it wasnt needed it was needed so i learned the hard way that the SPACER IS NEEDED, when we got it and finished putting it back together and firing it up from the previous owner the first time i actually got it to move it snapped the flex plate. now i know why. because there was no spacer. spacer fit perfectly everything lined up everything went back together perfectly 🤟🏼 so now to piece it back together here and figure out if this baby will fire. i need a new blow off valve mines leaking from the inside of it when i was running a boost leak test. this is the desired dsm life right? 😂😂💀


Without the spacer will also kill the fluid pump/front pump in your auto transmission as well. The end of the converter sits too far into the crank and it eats into the gear in the pump.
 
Without the spacer will also kill the fluid pump/front pump in your auto transmission as well. The end of the converter sits too far into the crank and it eats into the gear in the pump.
yes sir that’s exactly why i have never moved it under its own power til that gap was gone i did not want the same thing to happen again. everythings looking good now. fuel pressure after work and hopefully i can get her running tonight 🤟🏼
 
its always something right? after we got spark and connected to ecmlink we went to make sure the pump worked, so i took the line off at the rail and turned the key a bunch of times in acc and trying to start it, no prime no fuel coming out the line, so i shoot 12v at it and it turns on but again no fuel coming out no matter how long its on or how many times i cycled it, threw a known good working pump in there same thing turns out no fuel. 🤦🏻‍♂️ i put 2 gallons of fuel in there. felt like that should have been enough to get it thru the lines.

IMG_2460.jpeg


IMG_2461.jpeg
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top