The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Rix Racing
Please Support STM Tuned

2G Cruise Control, Speedometer, and Odometer/Trip gage stopped working 97 Eclipse GSX

rofljerry

5+ Year Contributor
86
2
Aug 18, 2014
MUSKEGON, Michigan
Hey guys, so I was driving down the highway and i had my cruise control on and suddenly im off C/C and my meters when out as well. I can still drive the car just fine I just have to use the RPM to indicate my speed. I still want to keep the C/C but what should I do about resolving this? Any help would be great. Thanks!
 

rofljerry

5+ Year Contributor
86
2
Aug 18, 2014
MUSKEGON, Michigan
I'm not too knowlegdable about repairs, if i just google cable replacements for them is it that easy?\
 

Billy Ciano

5+ Year Contributor
31
6
Apr 25, 2017
Sykesville, Maryland

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
Im curious if you solved your problem or not..Was it the VSS that was causing your CC and speedometer not to work?
I'm having the same problem a picked up a used one at the wrecking yard,it was identical to mine except the gear shaft was about 1" longer so i swapped shafts and everything fit up and bolted up fine.. but my speedOmeter an C/C still arent working..
Is your VSS a 3pin plug with a white gear
 

Turbo2g

Proven Member
280
50
Oct 13, 2017
Fallbrook, California
Your car is a 97, so it's got a nice easy OBD2 system to check codes and read data on if you have a scanner. Look for wheel speed sensor function/plausibility. I don't know how much information is available on these cars from the selection screen, but that's where I'd start if it came into my shop with these issues. I also look at the wiring and sensor(s) itself to see if there are obvious issues before going crazy on diagnosis.

I agree with the others that it's gonna be the speed sensor. But if could be a torn wire, or shorted due to other issues. Fluid leaks can fill the sensor socket and short it that way. Happens on O2 sensors a lot. Things below/back of the engine. Worth a look and a wiggle of the circuit before throwing a part at it. Check power and ground through the wiring etc. Of course if you don't have mechanical aptitude, trying a sensor is gonna be your easiest and best bet and hope that it works. If not, you'll have to go into deeper diagnosis.
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
Your car is a 97, so it's got a nice easy OBD2 system to check codes and read data on if you have a scanner. Look for wheel speed sensor function/plausibility. I don't know how much information is available on these cars from the selection screen, but that's where I'd start if it came into my shop with these issues. I also look at the wiring and sensor(s) itself to see if there are obvious issues before going crazy on diagnosis.

I agree with the others that it's gonna be the speed sensor. But if could be a torn wire, or shorted due to other issues. Fluid leaks can fill the sensor socket and short it that way. Happens on O2 sensors a lot. Things below/back of the engine. Worth a look and a wiggle of the circuit before throwing a part at it. Check power and ground through the wiring etc. Of course if you don't have mechanical aptitude, trying a sensor is gonna be your easiest and best bet and hope that it works. If not, you'll have to go into deeper diagnosis.
Thanks for your response turbo 2G...My car is a 99 GST Spyder 2.0l turbo...You very well could be rite..I have a new VSS coming tommorrow..I found on Amazon for $21.86..LOL OH GOD..You get what you pay for!!!..and yes I did hook up my scanner and there is no VSS registering on the data big 0..I'll post a response here as soon as I figure this out
 

motomattx

10+ Year Contributor
3,720
1,466
Dec 9, 2010
wampum, Pennsylvania
The vss drive ring in the transmission might have stripped out even, maybe check down there with a light to make sure its good to go too.
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
Thats a good call motomattix...Thats the first time I've heard that...I didnt even think about looking that direction...I'll be installing the new one hopefully tommorrow ...I'll let you know...thanks again guys
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
I installed the new VSS but still no speedometer...and as far as the vss drive ring i looked but couldnt tell if it was there or not.I cant get a real good look without taking off the throttlebody,which Im going to be swapping out here very soon..In the meantime I pinned a new connector and put on there and Im not so sure there connecting was looking at the connector today and the pins are further down inside the connector than the last one they were almost flush on the ends..so Im going to take the pins out and connect pin to prong without the connector..throw a little heat shrink around the ends so they dont short them out and..then I'll have a good connection then I can rule that out...I'll let you know
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
I installed the new VSS but still no speedometer...and as far as the vss drive ring i looked but couldnt tell if it was there or not.I cant get a real good look without taking off the throttlebody,which Im going to be swapping out here very soon..In the meantime I pinned a new connector and put on there and Im not so sure there connecting was looking at the connector today and the pins are further down inside the connector than the last one they were almost flush on the ends..so Im going to take the pins out and connect pin to prong without the connector..throw a little heat shrink around the ends so they dont short them out and..then I'll have a good connection then I can rule that out...I'll let you know
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
Wow..That didnt work...I clipped the new connector off and wiried in the old connector with new pins and still no speedometer...So I guess I'm onto tracing the wiring ,ground ,relay ,ecu..Im just learning how to read this electrical diagram I have for the 99 eclipse..so bare with me..I do have a question though ..what exactly is AC polarity?..the funny thing is I have some other electrical issues as well..blinker blinking to fast on Driverside and also just wired in some new projector headlights and the hi beam on driverside doesnt work either..Im not thinking there related to the VSS but not 100% sure either ...I am going to change out my throttle body hopefully tommorrow and i will look to see if I can see the drive ring in the trany...I was wondering should that drive ring be pretty visible and are those gears plastic as well?
 

knytespyder

10+ Year Contributor
33
4
Dec 7, 2007
Vancouver, Washington
VSS Fixed...woohoo...I took my throttlebody off today and removed my battery and tray and moved all the wiring harness out of the way I removed my VSS again and looked for the drive ring but still couldnt see it to much fluid so I put a stick down in there and I could feel some gear ridges on one side so I assumed that was the drive ring so then I cut the crimp connections I made the other nite for the new pins and soldered the connections this time heat shrinked and taped them all up then I installed the connector on to the VSS while I had it off the trany and with the wire keeper on this time (I didnt have it on last time it sprung off the connector and I lost it that nite)but I found it today LOL) and made sure the connector was seated on and locked on this time and Waaa Laaa I have speedometer...Those connectors have those rubber water tight seal in them that will keep your connector from making a good connection if there not locked on
thanks everyone for helping me out...much appreciated
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top