1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Alternator question

Posted by hoonigane, Aug 5, 2020

Please Support Rix Racing
Please Support Morrison Fabrication
  1. hoonigane

    hoonigane Proven Member

    122
    10
    Joined Jan 4, 2018
    Siauliai, Europe
    Today i replaced my alt with new one and 80 amp alt fuse just blown. Put in new one blew again. Did i connect everything right? And alt is 90 amp shouldnt fuse be 90amp too? The last alternator was 90amp too but it didnt blew. Any ideas?

    Also all my accessories like radio windows heater and such doesnt work. They are disabled when this fuse breaks right or did I fry everything?
     

    Attached Files:

    Last edited by a moderator: Aug 5, 2020
  2. Vegas Smith

    Vegas Smith Proven Member

    3,948
    1,759
    Joined Dec 2, 2002
    Houston, Texas
    There has to be a short somewhere.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    hoonigane likes this.
  3. hoonigane

    hoonigane Proven Member

    122
    10
    Joined Jan 4, 2018
    Siauliai, Europe
    Is it grounded in the right place? I took it out bout month ago and i dont remember
     
  4. pauleyman

    pauleyman DSM Wiseman

    5,859
    1,346
    Joined Nov 19, 2011
    oklahoma city, Oklahoma
    Where is the wire going to b terminal? You have nothing hooked up there.
     

    Street Build 3K  1

    1997 Eagle Talon TSi AWD
    awd · manual · 2G DSM
    Loading...
    hoonigane and TK's9d2TSi like this.
  5. luv2rallye

    luv2rallye DSM Wiseman

    7,746
    673
    Joined Jun 7, 2003
    Minneapolis, Minnesota
    Your Eclipse is the European version which may be slightly different than our USA version.
    However on our 2g turbo versions, the alternator fuse is a 100 amp and yes it supply's power to the fuses for power windows, radio and heater blower which most likely is the same on yours. Check the owners manual for the proper value of your alternator fuse. But it does sound like you have a short somewhere since it always blows.
     
    Last edited: Aug 5, 2020

    3K  0

    1999 Mitsubishi Eclipse GST
    14.200 @ 95.000 · 2G DSM
    Loading...
    hoonigane likes this.
  6. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,796
    1,396
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Pretty sure you’re missing the power wire to the fuse box and it’s grounded through the block

    62582FE6-3933-4AC7-9722-E773F7B44841.jpeg

    I swapped my alt for 90amp also and installed 100amp fuse. Been this way for about a year now without issues
     
    Last edited by a moderator: Aug 5, 2020

    450  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    506  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
    hoonigane likes this.
  7. luv2rallye

    luv2rallye DSM Wiseman

    7,746
    673
    Joined Jun 7, 2003
    Minneapolis, Minnesota
    Just make sure that yellow circled terminal really is the battery power connection and not just an additional ground point (or for a harness bracket like on ours).
     

    3K  0

    1999 Mitsubishi Eclipse GST
    14.200 @ 95.000 · 2G DSM
    Loading...
    hoonigane likes this.
  8. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,796
    1,396
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Check for continuity between that bolt and ground to confirm it's not a ground.
     

    450  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    506  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
  9. hoonigane

    hoonigane Proven Member

    122
    10
    Joined Jan 4, 2018
    Siauliai, Europe
    Thank you for your replies. The issue was i i atached b terminal in wrong place. Thats what happens when you take out your alternator and put it in month later. Everythings fixed thanks
     

Share This Page

Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing Raven Fabrication RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory