The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Rix Racing
Please Support STM Tuned

2G ***NEW PRODUCT*** Quaife rack and pinion AKA Quickrack, W/Optional EPS kits (CLOSED)

randman2011

10+ Year Contributor
530
254
Feb 26, 2012
Indianapolis, Indiana
I have had mine installed for a few months now. I opted for Brandon to shave the ports and used one of his cores. I also opted for the electric power steering. Everything works flawless and feels great.
I VERY much regret not opting for the EPS setup upfront. I have a Toyota column and controller but still haven't found someone to weld it together for me. I guess for sake of full disclosure I also had one of his cores shaved. Steering is great except for parking lots and alleys on my summer rubber.
 

josh408

10+ Year Contributor
1,731
115
Jan 29, 2011
Bay Area, California
Any updates @josh408 ? Anyone else get theirs on and using it? I haven't gotten mine on yet so might be a little worried now
He inspected mine he said the preload needed to be tighter, the looseness caused the shaft to pivot and contact the housing which is what caused the stiffness the entire time. Only possibility he could think of that caused it was the spring settled from his hands to install. He reset everything and should be shipping back to me today. I'll update after I get it back on a test drive.
 

Jerzm3

Supporting VIP
261
42
Jan 18, 2015
mount holly, New_Jersey
Nice!! with the electric, once power is applied, super smoooth. I opted for it because I had shoulder surgery years again and need to get it again, so I thought I would be nice to my shoulder since I keep putting off surgery! LOL
 

95REGF150

Proven Member
433
220
Mar 7, 2012
Elk Grove, California
Nice!! with the electric, once power is applied, super smoooth. I opted for it because I had shoulder surgery years again and need to get it again, so I thought I would be nice to my shoulder since I keep putting off surgery! LOL
Where did you get your EPS setup from?

I've also had mine installed since right after we got them. No issues. I sent in the core for mine. Gotta agree with the other comments, the best feedback you can get and even without the EPS driving is not bad at all unless completely stopped.
 

ec17pse

Freelancer
5,595
2,894
Nov 1, 2008
London, UK, Europe
Mines ok but it was built by Quaife so i think Josh's was a random fluke his got loose after being done up.

I just got done with my EPS also as trying to turn 275 or 295 tires is not very easy with no assistance!!! i can turn it while moving but not easily this wide so i had no choice but to go this route
 

Jerzm3

Supporting VIP
261
42
Jan 18, 2015
mount holly, New_Jersey
Where did you get your EPS setup from?

I've also had mine installed since right after we got them. No issues. I sent in the core for mine. Gotta agree with the other comments, the best feedback you can get and even without the EPS driving is not bad at all unless completely stopped.
I had my EPS setup done by Mr. Cole whole was referred to in the original deal.
 

Jerzm3

Supporting VIP
261
42
Jan 18, 2015
mount holly, New_Jersey
Can you give some feedback on your EPS unit by Mr.Cole? Is it rpm controlled? Does it shut off after you're already moving or stay on a suck power the entire time?
I believe it is just powered all the time. Only 3 wires were hooked up, 12V Power, ground and 12V Ignition.
 

josh408

10+ Year Contributor
1,731
115
Jan 29, 2011
Bay Area, California
I received the rack back from Brandon and on the bench feels more solid, I went to install it and I will say the feel of it from the steering wheel while on stands is more stiff since he adjusted to preload tighter. Just eye balled my toe and jump started the car and drove it around the block and it doesn't feel like I'm hitting a dead stop in the middle of a turn. It does feel difficult to turn at low speeds like <15mph but still need to test drive outside of where I live after I fully charge my battery this week since I had left the door cracked open one night like a genius. Already had the car decide to stall out but thankfully enough I was going down a steep hill to pop the clutch and get it started again. Will update later this week.
 

DSM98GSX

10+ Year Contributor
141
19
Apr 16, 2008
Tucson, Arizona
Anyone who has put theirs together, have some questions for you. I got Bobby's V2 kit with mine, so it's basically all brand new. I've looked and haven't found any definitive answers but did you torque the inner tie rod ends or just go tight? I have loctite to use on it as well. Also, did you put any extra grease on the gearing before installing the boots? Just want to make sure I do it right. Thanks in advance!
 

ec17pse

Freelancer
5,595
2,894
Nov 1, 2008
London, UK, Europe
Anyone who has put theirs together, have some questions for you. I got Bobby's V2 kit with mine, so it's basically all brand new. I've looked and haven't found any definitive answers but did you torque the inner tie rod ends or just go tight? I have loctite to use on it as well. Also, did you put any extra grease on the gearing before installing the boots? Just want to make sure I do it right. Thanks in advance!
Brandon would of greased up the rack and pinion for you so no need to add grease.

When i installed my kit I just did them tight and made sure they are snug. The factory lock washer does not fit great due to the bigger BJ and housing but you might be able to get it to kind of work. A dab of removeable loctite would also work.
 

josh408

10+ Year Contributor
1,731
115
Jan 29, 2011
Bay Area, California
Anyone who has put theirs together, have some questions for you. I got Bobby's V2 kit with mine, so it's basically all brand new. I've looked and haven't found any definitive answers but did you torque the inner tie rod ends or just go tight? I have loctite to use on it as well. Also, did you put any extra grease on the gearing before installing the boots? Just want to make sure I do it right. Thanks in advance!
I torqued the inner rods down to factory spec with blue loctite and the oem washer. I didn't put extra grease in as it looked pretty well greased out of the box. Let me know how yours feels after installing and test drive.
 

miguelmcv

Supporting Member
2,720
249
May 3, 2009
Fresno, California
Does anyone has contact Brandon lately ?

My rack has the same play and that’s only moving the shaft on the shelf, it has a lot of play with no force on it, I know once installed it will be worst.

I Email him last week and still no respond.
If anyone knows or have the info to contact him please let me know,
I don’t mind at all to pay for shipping, I just want the rack to be right.

Thank you guys in advance.
 

Flippy

Probationary Member
21
1
Dec 7, 2015
germany, Europe
Mine has the same problem.
I wrote him on his Mail Adress.
Let you Know when i get a reply
 

josh408

10+ Year Contributor
1,731
115
Jan 29, 2011
Bay Area, California
Does anyone has contact Brandon lately ?

My rack has the same play and that’s only moving the shaft on the shelf, it has a lot of play with no force on it, I know once installed it will be worst.

I Email him last week and still no respond.
If anyone knows or have the info to contact him please let me know,
I don’t mind at all to pay for shipping, I just want the rack to be right.

Thank you guys in advance.
I haven't contacted him since I had my issues. Last emails I had from him was this that might be the same problem I had with mine. Apparently my preload had changed after install causing torsional twist and I did notice the feeling seemed loose after I removed it from the car the 1st time. Didn't feel loose before going in the car. So not sure how that happened but sent mine back and he said only thing he noticed was preload was off. Maybe it's the same? I had mr.cole get me set up with the eps kit and the steering feels SO much easier. From a dead stop it's a bit hard to turn as if no power steering but as soon as I move its easy. I think the stiff feeling/struggle to turn before eps was my tire setup with a 9.5 inch with and the rubber compound on the tires that gave me the struggle if turning and would always have to hold tight when turning because the car wanted to center itself so much. Attached are what I feel might be relevant emails I had from him.

You must be logged in to view this image or video.


You must be logged in to view this image or video.
 

miguelmcv

Supporting Member
2,720
249
May 3, 2009
Fresno, California
I haven't contacted him since I had my issues. Last emails I had from him was this that might be the same problem I had with mine. Apparently my preload had changed after install causing torsional twist and I did notice the feeling seemed loose after I removed it from the car the 1st time. Didn't feel loose before going in the car. So not sure how that happened but sent mine back and he said only thing he noticed was preload was off. Maybe it's the same? I had mr.cole get me set up with the eps kit and the steering feels SO much easier. From a dead stop it's a bit hard to turn as if no power steering but as soon as I move its easy. I think the stiff feeling/struggle to turn before eps was my tire setup with a 9.5 inch with and the rubber compound on the tires that gave me the struggle if turning and would always have to hold tight when turning because the car wanted to center itself so much. Attached are what I feel might be relevant emails I had from him.

You must be logged in to view this image or video.


You must be logged in to view this image or video.
Thank you Josh I will try to contact him and see what we can do.

I will keep posting once I get in contact of him.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top