The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support RTM Racing
Please Support STM Tuned

1G 1g Speed sensor (reed switch) test and replacement

Greetings from Europe!

While trying to diagnose my cruise control not working, I found out that my speed sensor signal is absent.
I was looking for some information online on how to fix it and the only answer I found was - just replace the whole gauge-cluster.
Well, as you might imagine, these cars are getting more and more rare, so "just go find in junkyard" option might not always be available.

In this article I will guide you through how to test and fix speed sensor in 1g Eclipse for only 3 bucks and 30min of your time.

The easiest way to test if your speed sensor works without disassembling any of the interior is C-65 connector right next to left driver's foot.
We are looking for yellow-white pin 11.
You must be logged in to view this image or video.
You must be logged in to view this image or video.

Connect your multimeter either in voltage oscilloscope mode or just continuity testing mode.
Where the yellow-white pin as your positive and negative being grounding point anywhere in the car.



If your reed-switch is fine:
If testing with voltage oscilloscope, then turn on the cruise-control, as that should certainly give the needed 5V for the signal, if your ECU for some reason does not (I have evo8 ECU, so it doesn't provide required 5V)
With oscilloscope you will see something like, where signal jumps between 4.9V-0V, when your car is moving
You must be logged in to view this image or video.

With continuity tester you should hear continuity switching on and off again when car is moving, when it's standing it can either always be off or always on (depending on the position of magnet in the dash)

If your reed-switch is bad:
It's either going to be always 0V or 5V (have continuity or not), regardless of car movement.

So how do we fix it?

Need to disassemble the dash and get our gauge cluster out:
1) Two screws on the bottom of the dash bezel
2) Two screws on the top of the dash bezel
3) One screw behind the C-shaped molding on the right from the gauges
3) Remove the bezel
4) Four screws should be holding gauges cluster
5) Carefully pull out the gauges cluster, it should go very easily

Then carefully disassemble the gauges cluster:
1) To remove the "odometer button" just pull it out (I was slightly spinning it while pulling, it went easier that way)
2) Remove the front glass
3) Remove two screws holding the speedometer gauge plate and pull it up, it should remove the speed indicator arrow as well (barbaric, but effective)
4) Now there are only couple of screws holding the speedometer assembly inside the cluster from the other side

Now when we have speedometer assembly out:
You must be logged in to view this image or video.

You can go ahead and check once again the continuity between reed sensor pins while spinning the magnet, which is shown on the next image:
You must be logged in to view this image or video.


Note: interestingly enough, speedometer might still be working, while the speed sensor is dead, that's because speedometer relies on magnet + coil, while the speed sensor relies on magnet + reed switch.

If you confirm that reed switch is not changing the continuity (when you spin the magnet manually), then it's time to disassemble this whole thing.
Note: that reed switch might still work fine and switch continuity, if you bring some bigger magnet and put next to it, but if the original magnet cannot make it switch, then it has to be replaced.
1) Remove two main screws holding assembly together from the face side
2) Remove two screws from the side, which are holding reed switch pins in place
3) Carefully remove reed switch assembly
You must be logged in to view this image or video.
(reed switch assembly on the bottom, new reed switch on top, slightly smaller, but it doesn't matter)
4) Now you can split the assembly in half, be very careful doing that as all the plastic if quite brittle,

Note: be aware of the coil stop arm marked on the image (you should be able to move it out of the way by pushing it with something thin)
Yes, I broke the guiding pin of mine, that's why I'm mentioning this, but it's not critical, you will still be able to assemble everything back.

Soldering time, bring your new reed-switch ("normally closed" type) which costs ~3 bucks here in EU.
Oh and it doesn't have a polarity, so no worries.
You must be logged in to view this image or video.
(new switch in place)
You can test it without assembling anything - just use the bottom half of the assembly (where the reed switch is getting installed), and spin the magnet again.

Congratulations, now assemble everything back in reverse order!

PS: apologize for any weird wordings in english :)
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top