The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support STM Tuned

1G 1g Gauge Cluster Stopped Working

spadepro22

10+ Year Contributor
1,206
9
Mar 13, 2008
Seneca, South_Carolina
Got a 1993 AWD Talon and my gage cluster stopped working. I can still read values thew link, but nothing works on the dash besides speed and odometer. I did notice it went out after giving a jump so I checked every fuse in the car. Could be coincidence that it stopped working after that, just putting it out there. What to check for next before replacing the cluster?
 

91AwdBigRed

5+ Year Contributor
51
4
Aug 31, 2014
CLEARWATER, Florida
I would just try swapping the gauge cluster. You can get them for 10-15$. Worth a try.
 

Drewtsi

Probationary Member
8
1
Dec 16, 2014
Gambrills, Maryland
How did you check your fuses? The jump and the problem may not be related, but I like to cover all my bases. If you didn't check fuses with a test light or DVM then I would go back and do so. Also i don't know the locations of the grounds for that circuit, but it wouldn't hurt to check them. Yes the clusters can be had for $10-$20 so that's always a option as well as previously stated.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top