The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Rix Racing
Please Support Rix Racing

2G 1997 GS-T - No start after drive

saulofaria

Probationary Member
19
5
Jul 13, 2021
BEACONSFIELD, QC_Canada
Hello Everyone,
Well, I am stuck in a vicious cycle with my 1997 GS-T.
The car crank but struggles to fire during a cold start and most often after a short break (like going into a store and return to the car - engine is already at operating temperature) the car won't start.
I have attempted to fix the car by replacing the Fuel Pump, Fuel pressure regulator and Coolant Sensor. I have no more ideas how to go about this issue. I am bypassing the Fuel Pressure Solenoid but plugging the vaccum line from the Fuel Pressure Regulator directly to the intake manifold.
I hope someone can point me at the right troubleshooting here.
Thx
 

saulofaria

Probationary Member
19
5
Jul 13, 2021
BEACONSFIELD, QC_Canada
For mods just a down pipe Megan racing
No ECM link as far as I know.
the code I get is P1105(fuel pressure solenoid - I am bypassing that)
 

Dericsh

Supporting Member
1,277
518
Nov 25, 2002
Pearl River, Louisiana
Can you pull up a data list on your code reader while it’s not cranking and check the ECT temp reading? Verify the sensor/wiring it sending the correct signal to the ECM
 

saulofaria

Probationary Member
19
5
Jul 13, 2021
BEACONSFIELD, QC_Canada
Sounds like the fuel pressure solenoid on the firewall isnt connected. The fuel rail gets hot and the fuel boils, the solenoid burps the rail and the car starts.

So hook the vacuum line back up to the solenoid from the fuel rail
Hello @chrysler kid Yeah. it was like that but the solenoid needs to be replaced.

Hello @Dericsh Got the codes today, after clearning the codes and a 30 min drive I got the codes.
P0340- Camshaft Position Sensor "A" circuit Bank 1 or Single Sensor - This one is new. I need to review what has to be done about it.
P1400- Manifold Diff pressure sensor - I have already replaced the sensor MD305600, wasn't that suppose to resolve this issue?
P0505- Idle Control System - The Car Idles Perfectly
P1104 - Wastegate Solenoid - The car makes whistle noise when getting turbo pressure but there is no boost. Possibly this is the cultprit? I thought was my BOV going bad ?!
P1105 - Fuel Pressure Solenoid - That I know is bad, I don't have a replacement at the moment
 

Dericsh

Supporting Member
1,277
518
Nov 25, 2002
Pearl River, Louisiana
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Build Thread Updates

Vendor Updates

Latest Classifieds

Top