The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Morrison Fabrications
Please Support Rix Racing

16g install equals too much lag

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

domenico_169

20+ Year Contributor
428
0
Sep 17, 2002
Edmonton, Alberta_Canada
so i just finished insatlling a small 16g in my car with al hell lot of problems during the process, but anyways its in and heres the preoblem. i have WAY too much lag, lik ei dont hit full boost until about 5000 rpm, its stupid. what could it be?
 
WTF, that is way to high, maybe your Wastegate is stuck open or opening way too soon. Is your boost controller hooked up properly? Is there a nipple on the 16g compressor housing or on the lower IC pipe? If so it needs to be capped off with a vaccuum cap.
 
it is used but there was no shaft play, and it looks like its iin fairly good condition. i'll check for this nipple. any other ideas? and yeah i gotta do a boost leak test.
 
k so i put on my stock wastegate, and it fixed the problem, so i am hitting fulkl boost alot faster now. car is running much better, all i have to do now is find out where my stupid coolant is disappearing to and im good to go!
 
yup, damn wastegate!!! now i just need my uicp, mkiv smic, anf fuel pump and i should hit 12's... i hope!
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top