The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support STM Tuned
Please Support Feal Suspension

Recent content by moboostin

  1. I

    I see what your saying, that makes perfect sense. Yes everything worked perfectly when I connect those two pins but I will take your advice and go ahead and check the fuel pump relay, the wiring and connections today and yup the blue wire from the harness is connect to pin 86. As for the ecu...
  2. I

    Ill test the relay and see what happens, I haven't yet but ill defiantly check that out if not than I will trace the wire! Thank you!!
  3. I

    The relay for the pump rewire is literally brand new I guess I have to trace that wire and see what's up. Hopefully it resolves to something but either way what you mentioned with the key on seems like it'll just save me a headache lol
  4. I

    Will that bypass the MPI relay? I will give it a shot also will this take away from the 12v the pump gets from the relay? Thank you for your time and help!
  5. I

    I have a 95 talon with a 6 bolt swap that runs on an Aem v1 with a walboro 450. Everything worked fine till recently I connected a wrong plug to the idle switch sensor on the throttle body and it sparked.. Ever since than I was having issues with my fuel pump kicking on when turning the key. The...
  6. No lights working Help

    Yeah it’s brand new but i figured it out, kid that swapped the battery while i was at work connected the fuse box ground to the negative terminal not positive it’s all good now! Thank you for your input!
  7. No lights working Help

    hey guys I have a 91 gsx manual. Had a recent alternator issue. So far went through 2 of them guess there defective cause I still have a battery light on the dash but my main issue is even with the key on acc mode my headlights, tail lamps, brake lights, gauge cluster lights(battery light check...
  8. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    Figured i’d update everyone, i replaced the coolant temp sensor wires at the sensor they were a bit brittle and threw the 450s in there so far she starts up aboht 20 times back to back while fully warmed. I think she’s good now i haven’t repacked the iac yet or repacked the ecu with the burnt...
  9. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    Hey guys my apologies haven't been able to get back to y'all or the car, I was swamped wit school and exams. I did get a change today to mess with it so I removed the quick splices and took out the safc and avc-r out the harness and connected the green/blue wire back and FIRED right up Tried a...
  10. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    I know, it sucks wish I saw that before I bought it! Okay so that's what ill do than. ill just remove all those shitty wires cut them and connect the green and blue wire back right? As I have hopefully read correctly on the forums to get the maf sensor to work back to normal? This car also has...
  11. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    Okay I see what your talking about I really hope that's the case with this too! First thing tomorrow I'm on it, ill check the isc the way I was told as well as opening those blue things to check the connections and get those open ones covered and check the harness. Hope to find my issue there...
  12. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    2g maf harness looks good, i’m uploading the isc plug wires(it looks good?) Also here are the ecu harness wires not sure if it’s possible to see anything out the norm?
  13. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    Thanks a mill for that, will check using that way. Also that’s odd same driver blew on mine. You think i should just remove the safc and connect the maf sensor wire back in the harness ? I wouldn’t know how to fix the wiring i can remove it and going off the forums i can connect it back to how...
  14. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    So i checked the isc plug it’s in the right spot. I checked with a multimeter i got like 2.0 ohms on it outside the car guessing it’s bad i found another one laying around i tested it got 29 ohms i plugged the harness and left it out and turned the key to see if the sensor would move but it...
  15. 1G Help kind of stumped very hard cold starts than frying ECU's back to back

    Alright will do ill check the wiring out and everything, and I didn't ignore the link I checked It out I had just woken up haha ill test out the isc and see what's up, the maf is also using an adapter plug. I looked up the injectors they are some new ebay 550cc high impedance and I still have...
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory
Top