The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Rix Racing
Please Support ExtremePSI

Recent content by mattspyder

  1. mattspyder

    Clutch Problems?

    If I let off the gas it still does it. The speed is random, I've had it happen at 35-40, then while I'm cruising at 55-65. A friend of mine suggested that a rivet could've popped loose on the friction disk
  2. mattspyder

    Clutch Problems?

    less than 4k
  3. mattspyder

    Clutch Problems?

    anybody?
  4. mattspyder

    Clutch Problems?

    While driving to work this morning I had some potential clutch shudder going on. While I'm driving, all of a sudden the car starts shuddering. Vibration coming from the front. Once I push the clutch in it goes away. It comes back randomly. Could this be some clutch plate spring issues?I've got...
  5. mattspyder

    Clutch Issues

    The motor mounts are all new prothane mounts. I noticed that if I rev it up higher I don't get as much clatter.
  6. mattspyder

    Clutch Issues

    I replaced the TOB, the clutch kit and the flywheel. Yes the pedal is adjusted.
  7. mattspyder

    Clutch Issues

    I have some weird issues going on with my transmission. When I pull out in first gear, the clutch is grabbing and causing the car to shudder. This is only happening when I have the clutch pedal coming back out. The car shifts into gear fine. It's when I'm letting off the clutch it's grabbing...
  8. mattspyder

    Ufc 129

    watched this event last night and I was very pissed about the GSP fght. I'm tired of watching this guy go 5 rounds with guys. He hasn't finished a fight in awhile. I believe the super fight with Silva HAS to happen to save GSP's run to "greatness" However I was very happy with every other...
  9. mattspyder

    take off issues

    ok well that leaves that thought out.. hmm not sure what else it could be then
  10. mattspyder

    take off issues

    just thought I would update this post as I still have issues.the issue is still happening and i've put on about 1000 miles. Doesn't seem to be getting any better. It seems to be happening almost right at the top of the clutch play. It's like a sweet spot, I can even feel it now when i'm down...
  11. mattspyder

    can't clear check engine light

    like my profile says I have evoscan. I also have the ceddymod flash so I believe I could turn it off that waywould that explain why my wideband is reading lean
  12. mattspyder

    can't clear check engine light

    No. I've had it plugged in and not in the exhaust before with no issues.
  13. mattspyder

    can't clear check engine light

    I finally figured it out, after trying and trying I decided to go back into a virtual XP mode on my windows 7 machine and wouldn't you know. I can read the code, after all this time I forgot that I unplugged #2 02 sensor since I have a wideband in. I feel like such a idiot. Now my question is...
  14. mattspyder

    can't clear check engine light

    I can't pull codes. I can log. I know it doesn't make sense.
  15. mattspyder

    can't clear check engine light

    I can communicate to it because I can log in evoscan. that connects just fine. but just to make sure, where is that fuse located at? under the hood or by the clutch pedal?
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned
Top