The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support JNZ Tuning
Please Support Fuel Injector Clinic
98gstJames

Latest activityPostingsVehiclesAbout

    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Put a L on my block earlier and felt under each section with my feeler gauge and I couldn’t put the feeler garage underneath any part, I was measuring using .004” on my gauge. I’ll check the head to make sure it’s good as well but I was happy to...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Definitely a blown head gasket, honestly worse than I thought, kinda surprised at the psi numbers I had
      • B3807030-8526-4A67-9F3F-07D109DC88E7.jpeg
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      I can’t afford to have it machined at a shop but I have a buddy that has built his car and gone through the motor many times and has resurfaced before so I’m going to have him do it.
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      I wasn’t going to take to a machine shop to get it resurfaced I was just going to smooth it out myself, so then I assumed I’d just use the stock specs for a head gasket
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      I might not have mentioned it, but thank you for clearing up the sizing and is it also .056?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Well good news is I had already planned on pulling the head off first before I ordered it just to make sure there wasn’t anything else down inside, also I’ve done main bearing and piston rod bearing and pushed the pistons up to the top while...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      I did the wet test on it last week and the compression raised by about 2psi on the two low cylinders, I didn’t do #1 and #2 bc they were reading at 120 for #2 and 150 for #1 so then that made my assumption it’s blown in between cylinders 3 and 4...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      That’s what I was thinking but I thought the standard bore was 85mm and the only ones I can find that are 85mm are graphite ones and I’d rather not put a graphite head gasket in my car, so I was looking at cometic ones but I can only find it in...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Found a cometic head gasket on stm tuned and there’s different bore sizes along with thickness and I’m not sure what to get.
      • 533766D0-DAFD-4CB0-A911-BEB2461ACF4B.png
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Where’s the best place to get a head gasket?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      So I’m trying to find a tensioner and pulley for my eclipse and I’m not sure where the best place to look for one is, I found a couple online but I’m just unsure if the other brands will give me the same results that I need or what.
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      What is the td?Also I didn’t look at the ECT reading, I just looked to see that the 02 sensor said available/not completed instead of not available/not completed so there I just said it checked out.I also did the compression test again on...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      So if the coolant can leak into the ISC/IAC then into the fiav does it then leak into the cylinders? Should I be getting a new head gasket because of the compression reading?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Alright I’ll do that then unless I have other issues that are related to the coolant, does the compression test I did give any answers?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Yes the car was running before, I’m almost certain I didn’t overheat it but I’m not 100% sure on it bc I didn’t sit there and rev on it or anything like that, alright so basically by closing the loop that is to test the fiav gasket?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      So I got the coolant out and did a compression test and cylinder #4 tested at 90 psi,# 3 at 90 psi, #2 at 120 psi and # 1 at 150 psi. Am I correct it’s a head gasket along with the possibility of the fiav gasket?
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      What is the fiav gasket and where is it located? I wanted to do a compression test on it but I was going to after I had no leaks but the coolant in the cylinders kinda stopped me from trying to start it anymore to do a compression test.
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Could it be a blown head gasket? Or is there another way coolant can get in the cylinders? Also I’ll have to wait on the leak down test rn I don’t have the tools to do it.
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Got bad news… not so sure what it is but I hope it’s not what I think. So I finally got the o ring for my car and it put it on, put the thermostat housing on and then I put coolant in the car, plugged my obd2 in to see that the 02 sensor was...
    • 98gstJames
      98gstJames replied to the thread 2G Car still won’t start.
      Found the o ring on the thermostat housing pipe that runs to the water pump was stretched out and I’m assuming when the car started the pressure just made it smush out bc it didn’t hold a good seal, autozone ordered one for me last night and it...
  • Loading…
  • Loading…
  • Loading…
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory
Top