turn signal won't shut off

Posted by ross41, Sep 9, 2005

Please Support ExtremePSI
  1. ross41

    ross41 Proven Member

    53
    0
    Joined Mar 4, 2003
    n/a, Michigan
    Anyone have experience with the turn signal staying on? It's stuck blinking on the driver's side. I shut the car off and turned it back on, no luck. I can move the turn signal switch up and down and it makes no difference, it just keeps blinking. It's a 2G Eclipse.
     

    Log in/Register to remove ads
  2. mitsuchev

    mitsuchev Probationary Member

    4
    0
    Joined Aug 27, 2005
    Livonia(L-town), Michigan
    Now maybe i am way off here, but i had a similair problem on my '63 chevy II. the turn signal switch inside the steering column had messed up.
    there are little metal bands in the switch that when the turn signal lever moves, pushes the metal bands into each other, thus completing a curciut.

    what I had to do was pull everyhting off, and bend one of the metal bands into the correct position, i had no problems after that.

    now granted, this is a 42 year old american car, but i hope it helps.

    Matt
     
  3. T5Kthrasher

    T5Kthrasher Probationary Member

    25
    2
    Joined Jan 16, 2004
    Olympia, Washington
    I have this same problem with my 95 tsi, I have a replacement on the way from the ebay but b4 it gets here I think im going to pull mine apart and see if its fixable.
     
  4. luv2rallye

    luv2rallye DSM Wiseman

    7,279
    418
    Joined Jun 7, 2003
    Minneapolis, Minnesota
    If not the turn signal switch, it's a bad "Turn Signal and Hazard Flasher Unit". See if you can try a friend's 2g unit. It's vertically mounted behind the heater temp control.
     
    My DSM:
    1999 Mitsubishi Eclipse GST

    14.200 @ 95.000 MPH
    Loading...
  5. fuzzyturtles

    fuzzyturtles Proven Member

    31
    0
    Joined Feb 10, 2004
    cincinnati, Ohio
    I had the same problem. Its the turn signal relay. Kinda like a fuse. Why they didnt put it with all the other fuses is just retarded. Its located sortah behind the radio. If you turn the car on you can hear it clicking. just be warned its a pain in the a$$ to swap out. good news is that a new realay is only like 3 bucks at your local auto parts superstore. In the meantime you can just pull the fuse... you want have any signals but at least you wont be driving around w it goin off all the time. Hope this helps and happy modding :thumb: PS: dont foget abot the Reputatin points here in the newbie forums :D
     
  6. taino787

    taino787 Awaiting Email Verification

    42
    0
    Joined Feb 27, 2005
    albany, Georgia
    Im having the same problem. only my left front and rear lights are blinking. I purchased an "electronic flasher" (EP-34) from autozone this part is the size of a 9v battery but I cannot find where the part is located in the car to swap it out.
    26639.jpg
    TRIDON EP34

    The part that makes the clicking sound i BELIEVE is called the "hazard and TS relay" which is located behind the radio and is the size of a cigarette box. that part costs $61.00 at mitsubishi..


    CAN anyone help show me EXACTLY WHERE is the electronic flasher pictured below in the 2g Eclipse?
    26639.jpg
     
  7. mc_holla

    mc_holla Proven Member

    52
    0
    Joined Sep 22, 2003
    Covington, Georgia
    Im having that same turn signal problem with my DSM. Turned it on, made a left turn and now it stays on no matter what position the stalk is in. So im guessing that all i have to do replace that relay. If so, whats the best way to get to it?
     
  8. napkinthief

    napkinthief Proven Member

    1,032
    15
    Joined Apr 16, 2005
    Cliffside park, New Jersey
    Asking for reputation points can get you in trouble.
     
  9. taino787

    taino787 Awaiting Email Verification

    42
    0
    Joined Feb 27, 2005
    albany, Georgia
    I found the solution to my problem: :thumb: :thumb: :thumb:

    :tease: It was the turn signal/light switch. I opened it and found a small piece of plastic that was broke and prevented the lever from connecting inside.

    I tried to do some " :sneaky: jarhead engineering :sneaky: :sneaky: " but the piece was in a bad spot and i did not want take the risk for it to break once I assemble it.

    I purchased a new "TURN, UNIT" from Autzone for $61.30
    part #(Mitsu)MR277924 or (WELLS) SW1905.

    thanks for the help fellas. :thumb:
     
  10. mc_holla

    mc_holla Proven Member

    52
    0
    Joined Sep 22, 2003
    Covington, Georgia
    I fixed mine too. Same thing. I went to a salvage yard and they required that I buy the whole steering column for $50.00. And out of desperation and just the need to fix this problem, I did it. But $50 aint that bad considering the awkward feeling I had not having a turn signal. Thanks for everyones help.

    Oh.......If anyone wants a steering column minus the turn signal/headlight switch let me know.........I will practically give it to you.

    Mc
     
  11. wolf20043

    wolf20043 Proven Member

    861
    38
    Joined Mar 13, 2005
    pueblo, Colorado
    good thing you fixed it. It would suck driving in circles always turning left. Would feel like a NASCAR race. :p
    Mike
     
  12. mc_holla

    mc_holla Proven Member

    52
    0
    Joined Sep 22, 2003
    Covington, Georgia
    true true. LOL. never thought of that
     
  13. Eclipse45150

    Eclipse45150 Proven Member

    102
    1
    Joined Oct 1, 2004
    Milford, Ohio
    not the exact same prob, but have you had a prob of the turn signals flashing fast like a bulbs burnt out, but when I would change it it would go normal for a day or so then fast again, I think the relay is prob going but i dunno? Any suggestions?
     
  14. mc_holla

    mc_holla Proven Member

    52
    0
    Joined Sep 22, 2003
    Covington, Georgia
    I meant I did the same exact thing to fix my problem. The only thing I can think of is a relay or a short. I guess you could trace the wires and test the voltages.
     
  15. Defiant

    Defiant DSM Wiseman

    25,202
    122
    Joined Jan 13, 2003
    glorious Galt, California
    Odd, everyone here at The Home keeps their turn signal on all the time. Aren't we supposed to? WTF
     
    My DSM:
    Loading...
  16. lfrers

    lfrers Probationary Member

    2
    0
    Joined Feb 12, 2015
    san diego, California
    Bump. The most likely cause is a plastic bit in the turn signal assy broke. It must be a common prob because both my parts car and build car had the same issue. Sux that the 95 turn sign assy is not the same as the 97+ plugs are diff.
     

Share This Page

Loading...


Log in/Register to remove ads

Support Vendors who Support the DSM Community
Ace Race Parts Advanced Fuel Injection Archer Fabrication Boostin Performance ECM Tuning Extreme Turbo Systems ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions Jackson Auto Machine JNZ Tuning Magnus Motorsports Miller Import Parts Morrison Fabrication & Design OHM Racing Race Components Inc RockAuto RoadSurge Spultronix Performance STM Tuned Strictly Import Motorsports VR Speed Factory