1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Trouble Logging In or Staying Logged In?

    CLEAR YOUR BROWSER COOKIES! More info about this can be found here. If you still have trouble after clearing your browser's cookies and cache, reply to that thread and tell us what browser you're using and what device you're using.

intro/help

Posted by Afue, Oct 14, 2018

Please Support Morrison Fabrications
  1. Afue

    Afue Probationary Member

    16
    0
    Joined Oct 12, 2018
    sacramento, California
    Hello everyone, I'm new on here. I have a 97 eagle talon tsi awd. I'm having problem with my car not starting. It will crank but won't start. When the car is trying to start it will have a bogging sound like its not getting enough fuel. I swap out my fuel pump for enforce walbro 255 today and still the car wont start. Not sure what else to look for or to replace. Btw, when I have the ignition on I dont here any fuel running or here my fuel pump on or anything. Do any of you know whats wrong? Please help TIA.
     

    Log in/Register to remove ads
    My DSM:
    Loading...

    Featured Products from our Supporting Vendors

Share This Page

Loading...


Log in/Register to remove this ad

Support Vendors who Support the DSM Community
Ace Race Parts Archer Fabrication Best Used Tires Boostin Performance ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RockAuto SouthBay Fuel Injectors STM Tuned Tire Rack VR Speed Factory White Shed Speed