Innovate LC-1 Wideband Installation

Posted by c2ypt1c, Aug 20, 2012
Articles: Electrical & Wiring -

  1. c2ypt1c

    c2ypt1c Proven Member

    DSM Profiles:
    1
    Joined:
    Dec 5, 2009
    Posts:
    856
    Likes Received:
    36
    Southern, California
    This guide will show you the process of installing an Innovate LC-1 wideband o2 sensor. I installed mine in the front o2 location, effectively replacing the factory narrowband sensor. Here are my thoughts on the front o2 location:

    Many people feel that the front o2 is too close to the engine because of heat issues. However, many others have ran the LC-1 in this location for years with no such problems, and these "heat issues" are becoming more of a myth than anything. Placing the wideband in the o2 housing decreases the potential for exhaust leaks prior to the sensor and you don't have to weld another bung into the exhaust.

    OK, but isn't the factory narrowband best for closed loop operation? Yes, but v3 can simulate a narrowband signal exceptionally well. However, if a simulated wideband needs recalibration, this can affect closed loop operation.

    So the front o2 location has bung convenience and is virtually exhuast-leak-free. While a location further down offers optimal closed loop operation. I decided on the front o2 for my setup. Alright, enough preaching...on to the guide!

    Required Tools:
    Sockets and wrenches
    Breaker Bar (I used a 3/4" from Harbor Freight)
    (Optional) PB Blaster rust penetrant
    (Optional) A vise
    (Optional) Beer
    Anti-seize thread lubricant
    Solder iron, solder, and heat shrink
    Electrical wire and tape
    (Optional) Barrier strip (I purchased mine from Amazon: barrierstrip)
    Multimeter
    Coat Hangar
    Zip ties

    Installation:

    First and formost - *I WILL NOT BE HELD RESPONSIBLE FOR ANY DAMAGE YOU CAUSE BY FOLLOWING THIS GUIDE*
    Now that that's out of the way, jack the car up on jack stands and if need be, let the engine cool off.

    Next, remove the fan directly in front of the o2 housing. It is supported by four 10mm bolts (two on top, two on bottom).

    Remove the heat shield covering the o2 housing.

    Now, you can try to remove the sensor with a useless o2 socket, but you risk stripping the head of the sensor (which is what happened to me) OR you can remove the o2 housing and remove the sensor using a vise and a wrench. I went with the latter method...

    The o2 housing is mounted to the turbine housing via three 14mm bolts and one nut. First, spray the o2 housing bolts with rust penetrant. Spray some on the o2 sensor threads as well.

    While the penetrant seaps in, remove the two 19mm nuts that mount the downpipe to the bottom of the o2 housing. Careful not to drop them into the detached downpipe or you'll have to remove the exhaust and flip it upside-down to get it out...don't ask how I know.

    Remove the two nearest exhaust hangars to drop the downpipe further, giving you more room to work with.

    Now, back to the o2 housing. I was able to fit a breaker bar on all three bolts. The bottom, rear bolt was tough until I realized I could actually fit the breaker bar and socket on it. The nut (bottom, front) required a 14mm wrench (you can use a pipe for added torque).

    After they are broken loose with the breaker bar, a socket extention and/or swivel will help with removal:
    (Bottom, rear bolt)
    o2hsg2.jpg


    (Bottom, front nut)
    o2hsg3.jpg


    (Top, rear bolt)
    o2hsg4.jpg

    And the last bolt (Top, front) is so blatantly obvious and easy, there is no need for a picture...

    (Housing removed)
    o2hsgOff.jpg

    Remove the o2 housing and lock it in a vise. With some rust penetrator and a long 22mm wrench I was able to break the o2 sensor loose, even though it was slightly stripped:
    o2hsg1.jpg
    While unthreading the o2 sensor, it's a good idea to slightly tighten it back up, every-so-often, almost in a rocking motion, to help clear the threads. Keep doing this until the sensor is out.

    Now, apply some anti-sieze to the new wideband sensor's threads, as well as the o2 housing bolts. Using the same motion you used to remove the factory o2 sensor, thread the wideband into the o2 housing.

    Once the new sensor is in, re-install the housing.

    Don't bolt the downpipe back up yet. Leave it hanging. For now, you can re-install the heat shield and fan.

    You now need to fish the LC-1 wiring through the firewall into the cabin. I poked a coat hangar through the steering boot (from inside the car) to the engine bay. Then, I electrical-taped the wiring to the coat hangar and pulled it through:
    wireFish3.jpg
    Here you can see the hangar going through the steering boot

    wireFish1.jpg
    wireFish2.jpg
    At this point, be conscious of where you ultimately want the LC-1 controller located. Also, decide which path you want to route the wiring through (I placed my controller near the power steering reseviour - see last attached image below).

    Now it's time for some electrical engineering. Fire up that solder iron and get out the solder. Also, if you haven't done so already, disconnect your battery!

    Let me explicitly state that the ECU pins I mention from here on out are in regard to a 2g dsm. For a 1g, please refer to the ECU pinnout link provided in the reference section below.

    While the iron is warming up remove the driver side kick panel to get access to the ECU harness.

    Using a multimeter, determine what sources you'll use for switched 12v power and ground. You want a power source that is switched to the ignition. NOTE: if you have a turbo timer, consider tapping into it's power source.

    The cig-lighter is a good source for 12v switched power. It is the blue wire located behind the cig-lighter. For ground I used a nearby bolt. I wired these up to a barrier strip, like so:
    barrierStrip1.jpg
    NOTE: the red and blue LC-1 wires are the sensor's power and ground, respectively (see the wiring options link in the reference section below),

    Once you have power and ground taken care of, tripple check how you can identify pins 76 and 92 (see the ECU pinout link in the reference section).

    Remove the harness connector from the ECU. Making sure you have enough length for a soldered connection, cut pin 76 (front o2 signal) and strip the wire on the connector side. You can heat shrink/tape the other remaining wire.

    Now, solder the brown LC-1 wire to pin 76:
    pin76.jpg

    Next, the white LC-1 wire needs to be "spliced" into pin 92 (sensor ground), meaning, t-off the existing wire. Solder it up and heat-shrink all connections:
    pin92.jpg

    Reconnect the harness connector back to the ECU. Reconnect your battery.

    Calibration:

    Solder the push button and LED wires together, like so:
    pushButton.jpg
    NOTE: it doesn't matter which wires go where, just solder them together. Also, if you're waiting to install the wideband, you can do this if you're bored in the meantime.

    Connect the red/black (LED/pushbutton) wire to the black LC-1 wire, and the black/black (LED/pushbutton) wire to ground:
    pushb2.jpg

    Time to calibrate. Remember how you left the downpipe detached? The sensor has fresh air this way. You can use this technique to re-calibrate in the future (instead of removing the wideband). Follow the first time use and calibration instructions that came with the kit (see the Innovate Support link in the reference section below for the LC-1 manual).

    Configuration:

    After the sensor is calibrated, establish a connection in Ecmlink.

    Select the appropriate pin assignment and configure Ecmlink to simulate a narrowband signal:
    nbsim.png
    pinassign.jpg
    Click "Save pin assignments" and commit the changes to the ECU.

    Re-hang the exhaust hangars and bolt the downpipe back up. In Ecmlink start a data stream while logging the LC-1 signal. It should read full lean with the engine off at this point. Once, you verify a valid signal, fire up the engine! Now, re-verify you are getting a valid signal.

    Now zip tie the LC-1 controller/wires in the engine bay:
    lc1Location.jpg

    Congrats on your wideband install. Grab a(nother) beer, you deserve it!

    As always, feel free to pm me any questions/comments, and happy boosting!

    Resources and References:

    I want to thank snowborder714 for his guide:
    http://http://www.dsmtuners.com/forums/articles-electrical-wiring/421002-innovate-lc-1-installation-options.html

    And also turbosax2 for his:
    http://www.dsmtuners.com/forums/articles-tuning-ecu/281763-2g-turbo-ecu-pinout-w-wire-colors.html

    lc1install
    innovatelc1orlm1install
    v3narrowbandsim
    Innovate Support

    NOTE: I plan to update this article with the db gauge install and possibly an LC-1 firmware flash
     
    Last edited by a moderator: Jul 10, 2014
    #1
    snowborder714 likes this.

Share This Page