How can you tell if your ECU is bad???

Posted by S240161, Jul 26, 2005
Newbie Forum - Beginner DSM modification questions and discussions. Common, repetitive, and general discussions will get dumped here from other tech forums. Unless you're a Probationary member you shouldn't post threads here.

  1. S240161

    S240161 Probationary Member

    Joined:
    Jul 23, 2005
    Posts:
    21
    Likes Received:
    0
    San Diego, California
    How can you tell if your ecu has gone bad by looking at it? Anyone have any pictures showing what happens when a ecu goes bad??
    #1
  2. Cool Mr Steve

    Cool Mr Steve Proven Member

    Joined:
    Jul 18, 2004
    Posts:
    464
    Likes Received:
    11
    Spanaway, Washington
    You should tell us some of the symptoms your car is having... When my ECU went bad (twice) in my 95 Non-Turbo, the car would intermittently die. When it would die, I could tap the ECU and I would hear the car "click" back on. Damn engine mounted ECU's...
    #2
  3. HRNYHG

    HRNYHG Proven Member

    Joined:
    Aug 15, 2003
    Posts:
    44
    Likes Received:
    1
    , TexasUS
    You can open it up and see if the caps are leaking. It will also have a fish smell to it.
    #3
  4. Burnett03

    Burnett03 Proven Member

    Joined:
    Jan 20, 2005
    Posts:
    1,406
    Likes Received:
    13
    Aurora, Colorado
    if its turbo when you turn the ignition to on the boost gauge should jump (factory gauge) if it doesnt its fried.. or you have an eprom chip in it
    #4
  5. ndilo21

    ndilo21 Proven Member

    Joined:
    Aug 30, 2004
    Posts:
    257
    Likes Received:
    7
    void, New_York
    Is that 1g only because I'm almost positive my car doesn't do that.
    #5
  6. steve

    steve DSM Wiseman

    DSM Profiles:
    1
    Joined:
    Feb 3, 2002
    Posts:
    11,753
    Likes Received:
    146
    St. Charles, Illinois
    Go outside and check. Then tell us what your factory boost gauge does do when you turn the ignition on.

    Steve
    #6
  7. S240161

    S240161 Probationary Member

    Joined:
    Jul 23, 2005
    Posts:
    21
    Likes Received:
    0
    San Diego, California
    When I turn the car on the boost gauge goes a little under 0
    #7
  8. steve

    steve DSM Wiseman

    DSM Profiles:
    1
    Joined:
    Feb 3, 2002
    Posts:
    11,753
    Likes Received:
    146
    St. Charles, Illinois
    Sounds like yours is at least powering up. If it was totally dead the gauge wouldn't move. The other thing they do on power up is turn the CEL on for a few seconds.

    Steve
    #8
  9. S240161

    S240161 Probationary Member

    Joined:
    Jul 23, 2005
    Posts:
    21
    Likes Received:
    0
    San Diego, California
    I took some pictures of my ecu... can anyone tell me if this is my problem... I have checked the wires and they seem to be fine....

    Is that normal for all the wires to go out at once??

    Attached Files:

    #9
  10. steve

    steve DSM Wiseman

    DSM Profiles:
    1
    Joined:
    Feb 3, 2002
    Posts:
    11,753
    Likes Received:
    146
    St. Charles, Illinois
    Yes, the leakage damage is one of your problems. I revise my guess from before, you may not have blown the sensor ground. Your ECU Analog to Digital Converter (ADC) circuit is damaged among other things. That will cause you to throw lots of codes.

    Steve
    #10
  11. HRNYHG

    HRNYHG Proven Member

    Joined:
    Aug 15, 2003
    Posts:
    44
    Likes Received:
    1
    , TexasUS
    Get another ecu and your problems will go away
    #11
  12. S240161

    S240161 Probationary Member

    Joined:
    Jul 23, 2005
    Posts:
    21
    Likes Received:
    0
    San Diego, California
    Im trying to find one.... But I cant

    I have a 92 TSI Automatic

    No one has anything in a Auto
    #12

Share This Page