car jerking and sewage smell

Posted by Crackerjaxx, Oct 31, 2002
Newbie Forum - Beginner DSM modification questions and discussions. Common, repetitive, and general discussions will get dumped here from other tech forums. Unless you're a Probationary member you shouldn't post threads here.

  1. Crackerjaxx

    Crackerjaxx Proven Member

    DSM Profiles:
    1
    Joined:
    Jun 22, 2002
    Posts:
    11
    Likes Received:
    0
    wichita, Kansas
    :cry: well here is my problem i hope someone can help me out here.while driving my car the other day it started jerking around 3000rpms and a bad smell comes out(smells like sewage). it kinda sounds like the clutch is slipping. i have never had a clutch slip before so i can't say thats what it is. i do know that your rmps go up and you get a sewage smell but i don't know about the jerking part can someone explaain this part to me.
     
    #1
  2. Rob

    Rob Proven Member

    Joined:
    Aug 26, 2002
    Posts:
    705
    Likes Received:
    0
    , Cape_Coral_Fla_Sw
    the smell is most likely the clutch......the jerking is possible bad wires or bad spark plugs. just my 0.02 cents
     
    #2
  3. EROK006

    EROK006 Proven Member

    Joined:
    Oct 2, 2002
    Posts:
    21
    Likes Received:
    0
    WVC, SLC_UT
    Are you still running a cat? That could be clogged as well. I know when mine we bad on another car I had, it would rev past like 3000, and kinda smelt bad as well.
     
    #3
  4. quickersol

    quickersol Proven Member

    Joined:
    Oct 25, 2002
    Posts:
    120
    Likes Received:
    2
    , waite_park_mn
    check your electrical system, if your alternator is overcharging it will cause the acid in the battery to boil and smell like suffer (rotten egg smell)
     
    #4
  5. Crackerjaxx

    Crackerjaxx Proven Member

    DSM Profiles:
    1
    Joined:
    Jun 22, 2002
    Posts:
    11
    Likes Received:
    0
    wichita, Kansas
    i am still runnig a cat and i took in my starter to have it checked because i was have problems starting i took it in and had it tested it was pulling 250 so i bought a new one and it starts now i haven't checked the plugs and wires yet on my way to do that now and check the cat. thanks for info. so far. i did forget to mention that i does set and idle good only happens when im trying to drive
     
    #5
  6. Dsmed

    Dsmed Proven Member

    Joined:
    Apr 3, 2002
    Posts:
    495
    Likes Received:
    0
    , Cleveland_Ohio
    check your ecu caps and make sure they aren't leaking. You will smell a fishy smell inside the car and this also causes bucking.
     
    #6
  7. Crackerjaxx

    Crackerjaxx Proven Member

    DSM Profiles:
    1
    Joined:
    Jun 22, 2002
    Posts:
    11
    Likes Received:
    0
    wichita, Kansas
    i thank every1 who has giving me advice on my problem but it has been fixed. i have a friend who has a code scanner and it found that i was not getting any air flow readings so i was going to buy a new air flow senser sowhen the car was running and scanner hooked up i tapped the senser and it started running right but soon started acting up again so i bang it alittle more and now it is working great i have good idle and everything amazing what you find out by banging on something.hehehehe. thanks everyone for the info
     
    #7

Share This Page