alternator good but doesnt charge battery

Posted by matt98eclipse, Mar 11, 2011
Electrical Tech - Wiring, turbo timers, electronic boost controllers, gauges, fuses, wiring harnesses, wire tucks, car audio, and all other electrical component discussions.

  1. matt98eclipse

    matt98eclipse Proven Member

    Classifieds Rating:
    100%
    DSM Profiles:
    1
    Joined:
    Aug 15, 2006
    Posts:
    867
    Likes Received:
    0
    mesa, Arizona
    Hey guys im having a issue with my battery keeps draining. So i took my brand new battery and alternator down to Autozone and they tested both and they both turn out to be good. I had them test the alternator 4 times LOL and all 3 little test on the mechine passed all 4 times.

    So now my question is were do i begin checking all the wiring in the car LOL.??
    #1
  2. Usatuff

    Usatuff Proven Member

    Classifieds Rating:
    100%
    Joined:
    Sep 12, 2010
    Posts:
    305
    Likes Received:
    5
    New Windsor, New_York
    I would check the belt, wires on the alt and the relay
    #2
  3. boostd_mitsu

    boostd_mitsu Proven Member

    Classifieds Rating:
    100%
    DSM Profiles:
    1
    Joined:
    Sep 13, 2009
    Posts:
    103
    Likes Received:
    0
    Eau Claire, Wisconsin
    make sure the alt. fuse is good still. it is possible you have something drawing your battery down when its not running. if the fuse is good, take a test light, disconnect the positive battery cable and put the test light from the battery positive to the positive cable. if it lights up you have a draw.
    #3
  4. matt98eclipse

    matt98eclipse Proven Member

    Classifieds Rating:
    100%
    DSM Profiles:
    1
    Joined:
    Aug 15, 2006
    Posts:
    867
    Likes Received:
    0
    mesa, Arizona
    Just did your test and theres no draw. Im really leading toward the 4 pin connector that goes to the alternator. Witch wires or wire would cause the alternator to not charge the battery??

    I hooked up a test light. With the key on the acc postition the test light only comes on with the bigger red wire from the 4 wires coming off the connector.

    Please help guys i need this car up and running asap...

    Im not sure were the 4 wires from the connector go to to even trace them down.

    Sorry to bump guys but nobody knows?? I really need to get the car running.
    #4

Share This Page