2.4l spyder gs rough idle

Posted by 805DSM, Oct 27, 2009
Newbie Forum - Beginner DSM modification questions and discussions. Common, repetitive, and general discussions will get dumped here from other tech forums. Unless you're a Probationary member you shouldn't post threads here.

  1. 805DSM

    805DSM Proven Member

    Classifieds Rating:
    100%
    Joined:
    Jun 10, 2005
    Posts:
    206
    Likes Received:
    0
    Oxnard Shores, California
    Ok Just bought this 96 spyder gs 2.4 n/t with 99.xxx miles and all stock with NO CHECK ENGINE light on . The car was running and idleing good until afew days ago. I noticed it's running Rich at idle and the idle is lopey , drops to 450 then back up to 750rpm. I've done the whole maintanance on it an nothing has changed . Cheked for air leaks, broken/ripped vaccum lines and nothing .. THE CAR IS NON-TURBO so no I can't check for boost leaks.. And it's all stock , so what else should I check?

    Thanks

    Alex
    #1
  2. 95strandedDSmR

    95strandedDSmR Probationary Member

    DSM Profiles:
    1
    Joined:
    Sep 12, 2009
    Posts:
    27
    Likes Received:
    0
    Pittsburgh, Pennsylvania
    I just finally fixed a huge idle issue on my turbo 2.0 which was very lopey and unstable bouncing between 200-750 etc etc almost as if it souned cammed up, also smoked black smoke as if it was running rich.

    Problem ended up being the exhaust cam was out of time by 1 tooth. So it couldn't hurt to double check your timing marks on the motor.


    Simpler things to check would be IAC motor,and TPS sensor make sure they are both functional. They both adjust the idle and stability of the air coming through the throttle body into the manifold.

    I assume you already did the "maintence" thing like you said, plugs, wires, air filter, fuel filter, oil change etc etc.

    Could also check fuel injector o-rings. Im not sure how the PCV valve effects the non turbo 2.4 when its not functioning, but on my previous cars that were non turbo, a bad pcv has caused me some idle issues. Just some ideas hope you have some luck with it bud.
    #2
  3. 805DSM

    805DSM Proven Member

    Classifieds Rating:
    100%
    Joined:
    Jun 10, 2005
    Posts:
    206
    Likes Received:
    0
    Oxnard Shores, California

    Yeah , I changed the PCV valve and did all the maintanance on it, when I got it it would idle good and normal , then hear and there it would
    idle rough then it go back to normal. Now it's just idleing rough and running Rich at idle. I just need to check the timing marks
    #3
  4. 805DSM

    805DSM Proven Member

    Classifieds Rating:
    100%
    Joined:
    Jun 10, 2005
    Posts:
    206
    Likes Received:
    0
    Oxnard Shores, California
    Its been a while. It ended up being a bad EGR Valve, it was stuck open so it got replaced and Fixed the issue.
    #4

Share This Page