Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource on the web



















Login



Go Back   DSMtuners > DSM Forums > General > Newbie Forum
Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource
You are browsing the site as a GUEST. Please login (or register) and gain the ability to post on our site and interact with other DSMers. You also get to browse the site with fewer advertisements. It is FREE to join!

Newbie Forum: Beginner/newbie/general DSM modification questions. First mods, how to run 10's when you haven't run 12's yet, any tech question that doesn't fit in another tech forum. Probationary Members must limit their tech posts to this forum and sub-forums.

Reply
 
 
LinkBack   Thread Tools
Old 03-12-2010, 03:24 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #1 (permalink)
Probationary Member
 

techmaster330's Avatar
Registered: Nov 2009
Tech Posts: 16
Reputation: techmaster330 is an unknown

Acceleration Problems


OK to start I have a 96 Eclipse N/T and it does not seem to want to accelerate. I went to pass someone today but when I gassed it the only thing that happened was the RPM's started going way up. It seems to only do this in 4th and 5th gear but I haven't the slightest clue what may be wrong, any ideas?


mark post as helpful recommend reputation points    Reply With Quote
Old 03-12-2010, 06:13 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #2 (permalink)
Banana Republic
 

gofer's Avatar
Registered: Feb 2006
Tech Posts: 4,645
Photos: 65
Classifieds Rating: 14
Reputation: You can trust this leader of the site
Sounds like a slipping clutch to me.



____________________________
-Corey Jenson

E-OCHOCINCO Powered FP HTA68 / stock 7-bolt / Shep 4
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 03-12-2010, 06:51 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #3 (permalink)
Proven Member
 

Lavery's Avatar
Registered: Sep 2009
Tech Posts: 188
Classifieds Rating: 4
Reputation: Lavery is an unknown
Send a message via AIM to Lavery
I would say your clutch is starting to go. Always slips in the higher gears first, then gets worse until eventually the car wont move. Try adjusting your slave cylinder. And bleed the line if the clutch pedal is feeling soft/spongy
Visit Lavery's homepage! 

mark post as helpful recommend reputation points    Reply With Quote
Old 03-12-2010, 08:00 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #4 (permalink)
Proven Member
 

XyoungmurdaX's Avatar
Registered: Jan 2010
Tech Posts: 31
Photos: 4
Classifieds Rating: 0
Reputation: XyoungmurdaX is an unknown
i had the same problem some time ago its the clutch, it starting to slip
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 03-12-2010, 08:20 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #5 (permalink)
Proven Member
 

my dreamt dsm's Avatar
Registered: Jan 2007
Tech Posts: 1,627
Classifieds Rating: 4
Reputation: my dreamt dsm is more helpful than not
Dont even try to adjust the clutch cause most likely it isn't that. You will adjust and adjust to the point where there is nothing left in the clutch and then your going to have to find the right adjustment again.
I adjusted mines so much to grab the clutch that the worn out clutch was going to eat the flywheel.
Just change your clutch!


____________________________
Korrey's 98 GST 16g Powered

mark post as helpful recommend reputation points    Reply With Quote
Reply

Bookmarks

Thread Tools

 

» Recent DSM Photo
» Current Poll
How many times have you been to the Shootout?
1 - 40.00%
168 Votes
2-5 - 41.67%
175 Votes
6-10 - 10.48%
44 Votes
11-15 - 3.10%
13 Votes
16-20 - 4.76%
20 Votes
Total Votes: 420
You may not vote on this poll.
» Online Users: 863
217 members and 646 guests
Most users ever online was 1,704, 03-17-2008 at 09:11 PM.
DSMtuners Main Sections
DSM Forums
DSM Regional Forums
DSM Builds/Journals
DSM Articles
DSM Tech Guides
DSM Upgrade Paths
DSM Parts Reviews
DSM Vendor Reviews

DSM Classifieds
DSM Parts Guides
DSM Photos
DSM Videos
DSM Timeslips
DSM Dyno Sheets
Shirts & Apparel
DSMtuners Decals

Advertising Info
Our Sponsors
Site Rules
Terms of Service
Privacy Policy
Site FAQ
About Us
Contact Us

© 2014 DSMtuners.com - All Rights Reserved

DSMtuners is not affiliated with Diamond Star Motors. The Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, Mitsubishi Galant VR-4, and associated logos are trademarks of Diamond Star Motors, Mitsubishi Motors, and Chrysler Corporation. No, we do not hand out car sponsorships.

All times are GMT -7. The time now is 03:22 PM.


Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0