Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource on the web



















Login



Go Back   DSMtuners > DSM Forums > General > Newbie Forum
Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource
You are browsing the site as a GUEST. Please login (or register) and gain the ability to post on our site and interact with other DSMers. You also get to browse the site with fewer advertisements. It is FREE to join!

Newbie Forum: Beginner/newbie/general DSM modification questions. First mods, how to run 10's when you haven't run 12's yet, any tech question that doesn't fit in another tech forum. Probationary Members must limit their tech posts to this forum and sub-forums.

Reply
 
LinkBack   Thread Tools
Old 01-12-2010, 04:16 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #1 (permalink)
Proven Member
 

DSMe36's Avatar
Registered: Dec 2008
Tech Posts: 44
Photos: 10
Classifieds Rating: 0
Reputation: DSMe36 is an unknown

Not boosting?


Hi, im in a process of buying a gs-t but i have a few questions..

i test drove it and didnt feel like it pulled nor i even heard the turbo.
Wondering if it can be fixed. Maybe boost leak? idk im new to 4g63 engines, turbo engines for that matter.

but here are some pics, i saw that some of the lines arent connected right im guessing... and could this be aslo why the check engine light is on.
car has 95xxx miles, evo lll gt turbo?, manual boost controller, pretty much stock . Car ran fine, no funny noises of any sort, jus didnt boost.

I just wanna know if thats why it didnt boost. thanks..








View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:19 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #2 (permalink)
Proven Member
 

95dsmgsx95's Avatar
Registered: Sep 2009
Tech Posts: 54
Classifieds Rating: 0
Reputation: 95dsmgsx95 is on thin ice
check for boost leaks and see if the turbo has any shaft play

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:24 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #3 (permalink)
Proven Member
 

DSMe36's Avatar
Registered: Dec 2008
Tech Posts: 44
Photos: 10
Classifieds Rating: 0
Reputation: DSMe36 is an unknown
Quote:
Originally Posted by 95dsmgsx95 View Post
check for boost leaks and see if the turbo has any shaft play
Well i havent bought the car yet. So i cant do any of those.

If u look at the pictures closely, there are vacuum lines i think, that are connected to anything. and look at the turbo, isnt there a hose supposed to go there?
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:30 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #4 (permalink)
Proven Member
 

tkhaab_94's Avatar
Registered: Aug 2009
Tech Posts: 239
Photos: 14
Classifieds Rating: 1
Reputation: tkhaab_94 is an unknown
Send a message via AIM to tkhaab_94
The hose on the valve cover is supposed to hook up to your intake. As for the one on the turbo I think the hose that is supposed to go there is a coolant hose.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:37 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #5 (permalink)
Proven Member
 

joegamma1's Avatar
Registered: Oct 2009
Tech Posts: 152
Photos: 1
Classifieds Rating: 3
Reputation: joegamma1 is an unknown
the vacuum line on the side of the valve cover is the breather which should be connected to the intake just down from where the bov recirc house connects, it's ok to be open at the valve cover(not ideal, some people put small valve cover breathers there) BUT; the other end at the intake tube (if not connected or plugged) would suck in unmetered air which would effect how the cars runs, the tube at the back of the turbo looks like a coolant line, but they have been diconnected and left there because they found it easier to just run a new/different one, and i dont see a wastegate acuater on the turbo(may just not be visible in the pics) but it would not hold boost if the wastegate was allowed to just stay open. But you did mention a manual boost controller so it must have a wg, they may just have the boost turned down which i would consider "suspect". There may be other things wrong that the pictures do not tell us, so, to answer your question(can it be fixed) MY answer would be......i dont know, but if it runs decent even with drawing in unmetered air then it might be worth a look........ IF the price is right. You should be able feel the turbo spool up, although you may not hear it. Ask 'em to turn up the manual boost controller and see what happens. they might have just thrown the turbo on with no supporting mods so it cant be turned up very far, but it should still be able to hit 10-11 psi, which you would feel, i would think. hope this helps, the end(friggin novel!)
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:39 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #6 (permalink)
Proven Member
 

DSMe36's Avatar
Registered: Dec 2008
Tech Posts: 44
Photos: 10
Classifieds Rating: 0
Reputation: DSMe36 is an unknown
Wheres that coolant hose supposed to go?

and there are a lot of lines that are arent connected anywhere, lines jus chillen on its own.

Should i buy this car? he selling it for $3500
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:51 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #7 (permalink)
Proven Member
 

GettinPaper's Avatar
Registered: Aug 2009
Tech Posts: 279
Photos: 2
Classifieds Rating: 1
Reputation: GettinPaper is an unknown
Quote:
Originally Posted by DSMe36 View Post
Wheres that coolant hose supposed to go?

and there are a lot of lines that are arent connected anywhere, lines jus chillen on its own.

Should i buy this car? he selling it for $3500
I'd check the turbo for shaft play.
I'm guessing the turbo's shot.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 05:54 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #8 (permalink)
Proven Member
 

DSMDriver69's Avatar
Registered: Oct 2009
Tech Posts: 435
Photos: 6
Classifieds Rating: 1
Reputation: DSMDriver69 is an unknown
Quote:
Originally Posted by DSMe36 View Post
Wheres that coolant hose supposed to go?

and there are a lot of lines that are arent connected anywhere, lines jus chillen on its own.

Should i buy this car? he selling it for $3500
check for shaft play, just tell the guy if he really wants to sell it, you gotta take 15 mins and remove the air intake to check for any shaft play.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:00 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #9 (permalink)
Proven Member
 

helluvadsm's Avatar
Registered: Dec 2007
Tech Posts: 90
Photos: 4
Classifieds Rating: 4
Reputation: helluvadsm is more helpful than not
Heh, That car is hacked lol! Looks like a 2G also. I love the "evo III GT" never seen that before
The turbo doesnt even look like its being water cooled like its supposed to be, if it was, then the car would run out of coolant very quickly!
One thing I could tell you is, if you bought that car you would have to change that turbo out, and learn the vacuum lines so that you can re-do it all.
BTW 2G's need an install kit to have a 14B 16, 18, 20G ETC.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:01 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #10 (permalink)
Proven Member
 

joegamma1's Avatar
Registered: Oct 2009
Tech Posts: 152
Photos: 1
Classifieds Rating: 3
Reputation: joegamma1 is an unknown
Quote:
Originally Posted by DSMe36 View Post
Wheres that coolant hose supposed to go?

and there are a lot of lines that are arent connected anywhere, lines jus chillen on its own.

Should i buy this car? he selling it for $3500
no, better deals out there, my gsx was unmolested, BUT needed a clutch, for 1900 bucks
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:02 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #11 (permalink)
Proven Member
 

GettinPaper's Avatar
Registered: Aug 2009
Tech Posts: 279
Photos: 2
Classifieds Rating: 1
Reputation: GettinPaper is an unknown
Wait a second,
In the 1st picture it looks like that coolant line
that runs to the turbo isn't even hooked up to the thermostat housing
like it should be..
I own a 1g so it might be different, someone
correct me if i'm wrong.
But it looks like there's no coolant going to the turbo.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:14 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #12 (permalink)
Proven Member
 

constant_proj21's Avatar
Car: 1995 Moosetang GT
Registered: Jan 2009
Tech Posts: 397
Photos: 5
Classifieds Rating: 2
Reputation: constant_proj21 is an unknown
I don't see a wastegate, internal or external, anywhere in any of those pictures. That would be the boosting problem.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:25 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #13 (permalink)
Proven Member
 

DSMe36's Avatar
Registered: Dec 2008
Tech Posts: 44
Photos: 10
Classifieds Rating: 0
Reputation: DSMe36 is an unknown
Thanks for all the answers.

But yea i will take a look at it again.
and take a closer look. Ill take lots of pics as well.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 06:53 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #14 (permalink)
DSMtuners Supporting Vendor
 
Road Race Engineering 

Sam@RRE's Avatar
Registered: Apr 2008
Tech Posts: 281
Classifieds Rating: 2
Reputation: Sam@RRE is extremely helpful and trustworthySam@RRE is extremely helpful and trustworthy
Send a message via AIM to Sam@RRE
Missing wastegate actuator = no boost.
Visit Sam@RRE's homepage! 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-12-2010, 07:18 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #15 (permalink)
Proven Member
 

Colt4G63 also's Avatar
Car: AWD 90 Dodge Colt 4G63T
Registered: Jul 2008
Tech Posts: 2,589
Photos: 6
Classifieds Rating: 4
Reputation: Colt4G63 also is extremely helpful and trustworthyColt4G63 also is extremely helpful and trustworthyColt4G63 also is extremely helpful and trustworthy
It doesn't look like there's an oil line hooked up to that turbo either. If that thing works, then EVOIII GT's are the best turbos ever made.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-13-2010, 05:29 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #16 (permalink)
Probationary Member
 

VoodooXTC's Avatar
Registered: Jan 2009
Tech Posts: 9
Reputation: VoodooXTC is an unknown
I wouldn't buy the car if I were you. $3500 is WAY too much for something that could easily require $1000+ to be running right.

Look around for a better deal.

mark post as helpful recommend reputation points    Reply With Quote
Old 01-13-2010, 05:50 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #17 (permalink)
Proven Member
 

bkrathwohl's Avatar
Registered: Nov 2008
Tech Posts: 73
Photos: 11
Classifieds Rating: 7
Reputation: bkrathwohl is an unknown
Quote:
Originally Posted by VoodooXTC View Post
I wouldn't buy the car if I were you. $3500 is WAY too much for something that could easily require $1000+ to be running right.

Look around for a better deal.
I agree with XTC on this one, 3500 isnt a great deal. I would keep looking around for a car that runs normally for 3500.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-13-2010, 06:32 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #18 (permalink)
Probationary Member
 

Boosted99GST's Avatar
Registered: Jan 2010
Tech Posts: 2
Photos: 1
Reputation: Boosted99GST is an unknown
I would not buy it either. There are a lot better deals out there. Just be patient and don't be in a rush to get a turbo.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 01-13-2010, 08:24 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #19 (permalink)
Proven Member
 

EclipticalGS's Avatar
Registered: Aug 2008
Tech Posts: 1,133
Classifieds Rating: 6
Reputation: EclipticalGS is pretty helpful and trustworthyEclipticalGS is pretty helpful and trustworthy
omggaahh, what a nightmare that is. Hack job. Please do not buy that

mark post as helpful recommend reputation points    Reply With Quote
Old 01-13-2010, 09:47 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #20 (permalink)
Proven Member
 

dusty-gst's Avatar
Registered: Dec 2009
Tech Posts: 100
Photos: 11
Classifieds Rating: 0
Reputation: dusty-gst is an unknown
lol i would buy it for 2 grand
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Reply

Bookmarks

Thread Tools

 

» Recent DSM Photo
» Current Poll
How many times have you been to the Shootout?
1 - 40.00%
168 Votes
2-5 - 41.67%
175 Votes
6-10 - 10.48%
44 Votes
11-15 - 3.10%
13 Votes
16-20 - 4.76%
20 Votes
Total Votes: 420
You may not vote on this poll.
» Online Users: 989
285 members and 704 guests
Most users ever online was 1,704, 03-17-2008 at 09:11 PM.
DSMtuners Main Sections
DSM Forums
DSM Regional Forums
DSM Builds/Journals
DSM Articles
DSM Tech Guides
DSM Upgrade Paths
DSM Parts Reviews
DSM Vendor Reviews

DSM Classifieds
DSM Parts Guides
DSM Photos
DSM Videos
DSM Timeslips
DSM Dyno Sheets
Shirts & Apparel
DSMtuners Decals

Advertising Info
Our Sponsors
Site Rules
Terms of Service
Privacy Policy
Site FAQ
About Us
Contact Us

© 2014 DSMtuners.com - All Rights Reserved

DSMtuners is not affiliated with Diamond Star Motors. The Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, Mitsubishi Galant VR-4, and associated logos are trademarks of Diamond Star Motors, Mitsubishi Motors, and Chrysler Corporation. No, we do not hand out car sponsorships.

All times are GMT -7. The time now is 05:57 PM.


Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0