Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource on the web



















Login



Go Back   DSMtuners > DSM Forums > General > Newbie Forum
Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource
You are browsing the site as a GUEST. Please login (or register) and gain the ability to post on our site and interact with other DSMers. You also get to browse the site with fewer advertisements. It is FREE to join!

Newbie Forum: Beginner/newbie/general DSM modification questions. First mods, how to run 10's when you haven't run 12's yet, any tech question that doesn't fit in another tech forum. Probationary Members must limit their tech posts to this forum and sub-forums.

Reply
 
 
LinkBack   Thread Tools
Old 12-25-2009, 02:21 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #1 (permalink)
Proven Member
 

99Mitsu's Avatar
Registered: Apr 2009
Tech Posts: 103
Classifieds Rating: 0
Reputation: 99Mitsu is an unknown

my car is eating gas


OK, I last month I replaced my o2 sensor (the one by the turbo). My car was getting about 22mpg highway and 18 city. In the last week my car has been going through gas like water. I now go about 75 miles city and my gauge is at half. I dont see or smell anything wierd in my engine so i dont think its a gas leak.

Now I have an exhaust with no catalytic, I dont know it the o2 sensor could throw off my mixture if I have no cat.

please help
Merry Eclipsemas ~ Mitsu


mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 02:28 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #2 (permalink)
Supporting Freelancer
 
I sale snails 

pj91gsx's Avatar
Registered: Nov 2007
Tech Posts: 1,857
Photos: 5
Classified Ads: 1
Classifieds Rating: 84
Reputation: pj91gsx is more helpful than not
Send a message via MSN to pj91gsx
boost leak test.


____________________________
I sell and modify turbos and parts.
Austin
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 02:50 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #3 (permalink)
Proven Member
 

boostd_mitsu's Avatar
Registered: Sep 2009
Tech Posts: 103
Photos: 1
Classifieds Rating: 11
Reputation: boostd_mitsu is an unknown
hook it up to a scanner and see what the ect (engine coolant temp) is. if your temp sensor is bad they will read -44 and that will use alot of gas cause the computer thinks it that cold and is running very rich to warm up the motor faster. it won't always set a cel either so just check.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 02:51 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #4 (permalink)
Proven Member
 

dsmtun3r98gst's Avatar
Registered: Jan 2008
Tech Posts: 485
Photos: 7
Classifieds Rating: 7
Reputation: dsmtun3r98gst is an unknown
so your getting about 150 to a full tank??? well your going to find out that alot of dsmers are getting about 15-17 mpgs so its not like if your going to be a minority when it comes to that..... but like pj91gsx said: do a boost leak test.

Do you have a CEL?
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 03:00 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #5 (permalink)
Proven Member
 

Boost_Addict_88's Avatar
Registered: Dec 2008
Tech Posts: 93
Classifieds Rating: 7
Reputation: Boost_Addict_88 is an unknown
When was the last time you changed your plugs and wires? I had a similar gas mileage issue earlier this year. Turned out my plugs were sh!t (not to mention 3 Champions and a Boush). I had gotten the car about 5 months prior and hadn't had a chance to (nor did I pay it any mind for some reason) to change them. Needless to say, I was furious and I walked to Kragen for a new set of NGKs. Point is, after I changed them, I got better fuel economy. Also, check your fuel filter, air filter, and fill up with Shell (if you don't already). I've noticed very nice results when I use Shell gas vs others, but that's just my opinion.


____________________________
Kevin- '90 GSX "Canyon Carver"

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 03:09 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #6 (permalink)
Proven Member
 

rEclipserGST's Avatar
Registered: Nov 2007
Tech Posts: 1,289
Photos: 46
Classifieds Rating: 39
Reputation: rEclipserGST is an unknown
Send a message via AIM to rEclipserGST Send a message via Yahoo to rEclipserGST
Did you reset the ecu after the install of the o2 sensor?
Visit rEclipserGST's homepage!  View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 07:33 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #7 (permalink)
Proven Member
 

99Mitsu's Avatar
Registered: Apr 2009
Tech Posts: 103
Classifieds Rating: 0
Reputation: 99Mitsu is an unknown
@boostd mitsu; what kind of scanner do i need? would an OBDII scanner show engine temp?

@dsmtun3er; dont know what a CEL is and what do i need for a boost leak test

@boost addict; im running NGK plugs and wires, put them in back in july

@eclipserGST; since I dont have EMPROM i dont know how to reset my ECU

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 07:53 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #8 (permalink)
Proven Member
 

boostd_mitsu's Avatar
Registered: Sep 2009
Tech Posts: 103
Photos: 1
Classifieds Rating: 11
Reputation: boostd_mitsu is an unknown
an OBD2 scanner should show you live data, a CEL in a check engine light, and to reset the ecu all you have to do is disconnect to battery for like a minute or two. do you have a hard start condition?
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 07:55 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #9 (permalink)
Proven Member
 

dsmtun3r98gst's Avatar
Registered: Jan 2008
Tech Posts: 485
Photos: 7
Classifieds Rating: 7
Reputation: dsmtun3r98gst is an unknown
CEL= check engine light. and umm for a boost leak test you need a boost leak tester lol. you could either buy one or make one yourself. if you serch enough you can find one real easy. its a vacuum leak tester, they even sell em like at autozone
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 07:56 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #10 (permalink)
Proven Member
 

dSmgs-T's Avatar
Registered: Oct 2007
Tech Posts: 374
Photos: 2
Classifieds Rating: 4
Reputation: dSmgs-T is an unknown
A CEL is a check engine light.

i would do plugs, wires, fuel filter, maybe clean the injectors and definitely do a boost leak test.


____________________________
1997 tsi- sold
1995 awd- stroked'n'poked
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 07:57 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #11 (permalink)
Proven Member
 

dsmtun3r98gst's Avatar
Registered: Jan 2008
Tech Posts: 485
Photos: 7
Classifieds Rating: 7
Reputation: dsmtun3r98gst is an unknown
Quote:
Originally Posted by boostd_mitsu View Post
an OBD2 scanner should show you live data, a CEL in a check engine light, and to reset the ecu all you have to do is disconnect to battery for like a minute or two. do you have a hard start condition?
Not all OBD@ scanners have that capability.... you have to get the really expensive ones. maybe a few cheaps ones may have it as well not quite sure
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 11:28 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #12 (permalink)
Proven Member
 

oneslowwdsm's Avatar
Registered: Mar 2009
Tech Posts: 169
Photos: 4
Classified Ads: 1
Classifieds Rating: 6
Reputation: oneslowwdsm is an unknown
Quote:
Originally Posted by dSmgs-T View Post
A CEL is a check engine light.

i would do plugs, wires, fuel filter, maybe clean the injectors and definitely do a boost leak test.
I don't think that would cause less than 20mpg.


What kind of mods are you running? Stock fuel pump and such? My car is bone stock and I get 30mpg freeway and around 24-25 city.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 11:44 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #13 (permalink)
Proven Member
 

rEclipserGST's Avatar
Registered: Nov 2007
Tech Posts: 1,289
Photos: 46
Classifieds Rating: 39
Reputation: rEclipserGST is an unknown
Send a message via AIM to rEclipserGST Send a message via Yahoo to rEclipserGST
Quote:
Originally Posted by oneslowwdsm View Post
I don't think that would cause less than 20mpg.


What kind of mods are you running? Stock fuel pump and such? My car is bone stock and I get 30mpg freeway and around 24-25 city.
Wow you must have a super car
Visit rEclipserGST's homepage!  View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 12-25-2009, 11:46 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #14 (permalink)
Proven Member
 

oneslowwdsm's Avatar
Registered: Mar 2009
Tech Posts: 169
Photos: 4
Classified Ads: 1
Classifieds Rating: 6
Reputation: oneslowwdsm is an unknown
Quote:
Originally Posted by rEclipserGST View Post
Wow you must have a super car
No?

http://i136.photobucket.com/albums/q...IMAG0081-1.jpg

Proofz
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Reply

Bookmarks

Thread Tools

 

» Recent DSM Photo
» Current Poll
How many times have you been to the Shootout?
1 - 40.00%
168 Votes
2-5 - 41.67%
175 Votes
6-10 - 10.48%
44 Votes
11-15 - 3.10%
13 Votes
16-20 - 4.76%
20 Votes
Total Votes: 420
You may not vote on this poll.
» Online Users: 907
258 members and 649 guests
Most users ever online was 1,704, 03-17-2008 at 09:11 PM.
DSMtuners Main Sections
DSM Forums
DSM Regional Forums
DSM Builds/Journals
DSM Articles
DSM Tech Guides
DSM Upgrade Paths
DSM Parts Reviews
DSM Vendor Reviews

DSM Classifieds
DSM Parts Guides
DSM Photos
DSM Videos
DSM Timeslips
DSM Dyno Sheets
Shirts & Apparel
DSMtuners Decals

Advertising Info
Our Sponsors
Site Rules
Terms of Service
Privacy Policy
Site FAQ
About Us
Contact Us

© 2014 DSMtuners.com - All Rights Reserved

DSMtuners is not affiliated with Diamond Star Motors. The Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, Mitsubishi Galant VR-4, and associated logos are trademarks of Diamond Star Motors, Mitsubishi Motors, and Chrysler Corporation. No, we do not hand out car sponsorships.

All times are GMT -7. The time now is 08:09 PM.


Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0