Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource on the web



















Login



Go Back   DSMtuners > DSM Forums > General > Newbie Forum
Welcome to DSMtuners - the largest Mitsubishi Eclipse, Eagle Talon, 4G63t and 420A DSM performance resource
You are browsing the site as a GUEST. Please login (or register) and gain the ability to post on our site and interact with other DSMers. You also get to browse the site with fewer advertisements. It is FREE to join!

Newbie Forum: Beginner/newbie/general DSM modification questions. First mods, how to run 10's when you haven't run 12's yet, any tech question that doesn't fit in another tech forum. Probationary Members must limit their tech posts to this forum and sub-forums.

Reply
 
 
LinkBack   Thread Tools
Old 04-13-2008, 03:40 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #1 (permalink)
Proven Member
 

sleepypsi's Avatar
Registered: Mar 2008
Tech Posts: 31
Classifieds Rating: 0
Reputation: sleepypsi is an unknown

Replaced head gasket Still white smoke help!!!


I just replaced my head gasket, the head wasn't warped. After I got it back together It started right up but idled at 3000 rpm. White smoke was still coming out of the exhaust but it didn't smell like antifreeze like before and water didn't mix with the new oil. I let it run a while to try to trouble shoot it, I idled it down with the idle screw. I unplugged the mass air sensor from the filter and the idle didn't change. Before If i'd do that the car would cut off or idle really bad. Any ideals??? Thanks!


mark post as helpful recommend reputation points    Reply With Quote
Old 04-13-2008, 04:49 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #2 (permalink)
Proven Member
 

InvaderGSX's Avatar
Registered: Jul 2004
Tech Posts: 126
Photos: 5
Classifieds Rating: 84
Reputation: InvaderGSX is more helpful than not
Your turbo might be wasted. Your idle might be off because your throttle cable is jacked up after you put it back together. Throttle cable is either put on wrong or you have it pulled out too far. Check that out.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 04-13-2008, 04:53 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #3 (permalink)
Proven Member
 

robbo185's Avatar
Registered: Sep 2005
Tech Posts: 184
Photos: 1
Classifieds Rating: 2
Reputation: robbo185 is an unknown
Send a message via AIM to robbo185
did you mill the head or the block?? Did you take it to a machine shop to make sure it was level?

What type of headgasket did you use?
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 04-13-2008, 04:56 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #4 (permalink)
Proven Member
 

silver bullit's Avatar
Registered: Jan 2006
Tech Posts: 1,540
Photos: 11
Classifieds Rating: 20
Reputation: silver bullit is more helpful than not
Turbo may be a prob, maybe, how is the in/out side to side shaft play?.
Head not installed correctly or torqued correctly, maybe.
All the coolant coming out of the exhaust left overs of the last head cause you did not clean all the coolant out of the exhaust, More then likely this is you answer.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 04-15-2008, 08:53 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #5 (permalink)
Proven Member
 

sleepypsi's Avatar
Registered: Mar 2008
Tech Posts: 31
Classifieds Rating: 0
Reputation: sleepypsi is an unknown
Ok i've been trouble shooting a little more. Now I can put my hand over the muffler while the car is at idle and i'll get antifreeze on my hand and there is also water mixed with the oil again. I used a fel-pro headgasket ( I know there crappy) I cleaned the head and block up and installed the head gasket and torqued it in three steps 35,55,72 lbs following the manual. It started smoking white on start up. Now when I start it, it runs fine for about two mins then starts smoking. I didn't take the head to the machine shop because I didn't think it was warped because I didn't get it real hot and I drove the car a few times after I fixed the coolant problem and it hadn't blown. It seemed that the gasket just got weak and gave way. The turbo would spin free and didn't have any shaft play. The engine has 400 miles on it since its been re-ringed and a new turbo. Can oil/water mix in the turbo?? Thanks for any info!!!

Heres my mods..... EVO III Big 16g ported, 2nd gen pistons, HK$ 264/272 cams, ARP Head Studs, Fluidyne radiator, Balance shafts removed, 2nd gen ported manifold, ported O2, Supra Sidemount, 2nd gen MAS, Dejon intake, walboro 255lph, S-AFC, turbo-back exhaust, ACT2600, SS clutch and brake lines, big brake upgrade with powerslots , KYB struts, A/F & Boost gauge, Blitz dual turbo timer, Greddy electronic boost controller, Greddy EGT gauge, 550cc injectors, Manual steering rack

mark post as helpful recommend reputation points    Reply With Quote
Old 04-15-2008, 09:33 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #6 (permalink)
Proven Member
 

InvaderGSX's Avatar
Registered: Jul 2004
Tech Posts: 126
Photos: 5
Classifieds Rating: 84
Reputation: InvaderGSX is more helpful than not
Fel Pro headgasket is fine. It's just like a stock OEM one. My question is did you reuse your stock head bolts? If you did that could be your problem. Stock head bolts should never be reused. If they are ARP headstuds don't be scared to torque them down to 80 to 85. Good chances on an overheat that you warped the head. And if you overheated it bad you could have wasted your piston rings again. So many scenarios.
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 04-16-2008, 08:48 AM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #7 (permalink)
Proven Member
 

sleepypsi's Avatar
Registered: Mar 2008
Tech Posts: 31
Classifieds Rating: 0
Reputation: sleepypsi is an unknown
Thanks for the info I guess i'll take it back apart and take the head to a machine shop. The arp head bolts were only hand tight when I took the head off, is that the way they are suppose to be?? I torqued the nuts to 72 lbs.

mark post as helpful recommend reputation points    Reply With Quote
Old 05-02-2008, 07:04 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #8 (permalink)
Proven Member
 

mnetwork's Avatar
Registered: Feb 2006
Tech Posts: 863
Photos: 2
Classifieds Rating: 7
Reputation: mnetwork is an unknown
Send a message via AIM to mnetwork
Quote:
Originally Posted by sleepypsi View Post
Thanks for the info I guess i'll take it back apart and take the head to a machine shop. The arp head bolts were only hand tight when I took the head off, is that the way they are suppose to be?? I torqued the nuts to 72 lbs.
What ever happend with this? I'm very curious...


____________________________
~Mark
97' PTE 6262SP + E85 Powered Eagle Talon
Visit mnetwork's homepage!  View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Old 05-02-2008, 08:07 PM Show Printable Version Show Printable Version   Email this Post to a Friend Email this Post      #9 (permalink)
Proven Member
 

mndsm1's Avatar
Registered: Apr 2008
Tech Posts: 86
Photos: 5
Classifieds Rating: 1
Reputation: mndsm1 is an unknown
likewise..
View photos of this member's car 

mark post as helpful recommend reputation points    Reply With Quote
Reply

Bookmarks

Thread Tools

 

» Recent DSM Photo
» Current Poll
How many times have you been to the Shootout?
1 - 39.86%
167 Votes
2-5 - 41.77%
175 Votes
6-10 - 10.50%
44 Votes
11-15 - 3.10%
13 Votes
16-20 - 4.77%
20 Votes
Total Votes: 419
You may not vote on this poll.
» Online Users: 581
155 members and 426 guests
Most users ever online was 1,704, 03-17-2008 at 09:11 PM.
DSMtuners Main Sections
DSM Forums
DSM Regional Forums
DSM Builds/Journals
DSM Articles
DSM Tech Guides
DSM Upgrade Paths
DSM Parts Reviews
DSM Vendor Reviews

DSM Classifieds
DSM Parts Guides
DSM Photos
DSM Videos
DSM Timeslips
DSM Dyno Sheets
Shirts & Apparel
DSMtuners Decals

Advertising Info
Our Sponsors
Site Rules
Terms of Service
Privacy Policy
Site FAQ
About Us
Contact Us

© 2014 DSMtuners.com - All Rights Reserved

DSMtuners is not affiliated with Diamond Star Motors. The Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, Mitsubishi Galant VR-4, and associated logos are trademarks of Diamond Star Motors, Mitsubishi Motors, and Chrysler Corporation. No, we do not hand out car sponsorships.

All times are GMT -7. The time now is 06:47 AM.


Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0